Export Stuck at Restoring Packages


It was working before and today it’s not, I’m not sure what changed but it is now impossible for me to export anything. The exporter get stuck at Restoring packages

See full log here : Generating project files (this may take up to a few minutes)[Verbose] Running - Pastebin.com

For info :

So far I tried to :

Restart Windows
Reinstall Gamma 2021.4.10
Install Previews of 2021.4.11
Export different help patches.

Looks like you’re experiencing the bug reported here :

Does not fail at the same step but the VS versions seem to match, so maybe that helps!

Unfortunately it didn’t work but the log seems different though :

While building with VisualStudio following @Elias post it throws those errors : EXEC : error 3.619s: [AssetCompiler] Unexpected exception while loading project - Pastebin.com

Which seems to be the same as described.

OK so the workaround from @Elias does work and it has to be done using the Developer Command Prompt from Visual Studio 2019 only (I didn’t pay attention at first that I was using the Command Prompt from VS 2022).

We had three machines were it worked fine in the VS 2022 command prompt. I believe they didn’t have VS 2019 installed at all.