Ether-dream ILDA


#1

Hi All

does any of you have any experience with the ether-dream ILDA interface? looks pretty clever with network instead of USB. http://ether-dream.com/

sunep


#2

Hello

did you find a way to feed the ether dreem?


#3

works very well to my knowledge:


#4

problem solved :) (yes it works) thanks anyway


#5

Hi all, mostly @tonfilm

I get red nodes when running the help file, the EtherDream node is red. It references the file: “\bin\release\VVVV.LaserDAC.dll” and the folder \release does not exist.

Could someone give me some directions to getting this working?

Sune


#6

Hello!
I’m having the same problem @sunep has. Does anybody know how to fix it?

C


#7

Opening the LaserDAC (Devices) help.v4p falls back onto the VVVV.LaserDAC.csproj as dynamic plugin …

If you really need the dll, open up the solution in VS and set the configuration to Release, build it, done.


#8

Hey there,

My turn to try out the EtherDream node!

I do have the EtherDream node ok (both not-red-dll or dynamic versions) but I can’t see any activity from the Etherdream; and also in Wireshark I cannot monitor any frame out to port 7765 which I read was the listening port of Etherdream.

If I use the dynamic version though, I can read from a TTY that it could not load EtherDream.dll, while it sits in the same folder.
I also tried adding a reference to the file from the Project Browser (CTL-J) but it doesn’t help.

Any ideas?
Thanks!

T


#9

Found out it works out of the box with vvvv x86.
So I guess the problem is the Etherdream.dll is only x86 right?
Do you guys confirm that, or does any of you got it to work on x64?


#10

Right, x86 only…


#11

Hey @tonfilm ,

Yeah Jacob from Etherdream confirmed the dll was x86; but said we could compile it as x64 from the source on Github, so I might look into that later to spare running a separate instance.

I think something might not work as expected in the blanking feature though. When drawing distinct shapes (like the 2 circles from your help patch) points are still being drawn during the travel between end of shape 1 and start of shape 2. (probably just a matter of adding extra pause).

That’s something I can look into and share the changes if I get anything interesting.
But I can’t have the dynamic plugin to compile. Even if I add a reference to the dll in the Project manager, I get a “CS0009 error: can’t open metadata file”. Is there something I’m missing?
First time I’m linking extra dll’s in a dynamic plugin, so please excuse if that’s a noob question :)

T


#12

All good!

  1. I found out the problem was the dll being unmanaged, which thus couldn’t be added as a regular reference and required a proper wrapper. I’ll probably write a little forum post right after that as a “third-party-dll-in-plugins 101” in case someone is stuck in similar situation.

  2. As a free bonus, attached is a x64 version of the EtherDream.dll that I compiled from source, in case anyone needs it.

T

EtherDream_x64.zip (181.8 KB)


#13

that’s very nice…

have you seen this node, it should contain everything, including a wrapper for the EtherDream.dll:

was it missing something or what is the reason that you want to write your own c# wrapper?


#14

Yes indeed!
See my above:

  1. I was looking for a 64 version to spare having a separate instance
  2. I think there’s something to fix (or improve?) regarding blanking

For that reason I was trying to get the dynamic plugin version to compile; and now I’m all set!
I’ll post my findings here for sure!


#15

ah, you are starting from the code base, makes sense. so if you have an update… please make a pull request from your fork on the repo. thanks!


#16

guys I need one of those interfaces
how much are they ?


#17

I’d love to try, but I get red node for EtherDream.dll as well, any hints ?


#18

hi joanie,

it only works with 32-bit vvvv. latest code on github should work fine it was used recently by https://vvvv.org/businesses/experienss

you could contact them and ask how they did it… to my knowledge they even used multiple devices at once.


#19

Is this supposed to work with Etherdream2 ?


#20

if the software api is the same in this dll then yes: https://ether-dream.com/downloads-ed2.html