Forum

Errors at startup with Alpha27.1

Hello devvvvs!

I get this errors at the startup with the latest version of Alpha27.1
I don’t know if it is related to VVVV or the latest Vlc0.5 version.
Anyway I attached the file with the errors.

Greetings :)

errors Alpha27.1.txt (29.4 kB)

ai, is this plain vvvv starting up? or with addonpack? or with additional contributions? or even with a patch? if there is a patch and it is simple it would help if we could get it. if it is not simple, please try to simplify it…

I started it with addonpack and the Vlc plugin. I get the same issue with Vlc0.3 and Vlc0.5

It only happens when I open my patch in VVVV. VVVV without any patch doesn’t give me that errors… Even the TTY renderer gives me errors, but my patches seems to be fine because there aren’t any red nodes and I don’t have these problems with beta26.

Unfortunately the patch is really huge and complex… :( I’m working nearly two years on it!
At the moment I’m very busy with my dissertation, but after (at the end of march) I would have more time to isolate the problem creating elements.

Ciaooo! :)

Hey Joreg!

The errors come even without the Vlc plugin in Alpha27.1
So It can’t be that.

I attached another version of the errors.

Greetings! :)

errors Alpha27.1 without VLC.txt (22.1 kB)

The TTY renderer tells me that line…

00:00:46 * : [mainloop, prepare graph](mainloop, prepare graph) unexpected error: Access violation at address 172AC840. Write of address 00000057

Maybe the Mainloop node is causing the issue…

you say you don’t have this error in beta26, what about beta27?

I have other issues with beta27…
For example a strange behaviour with the CreateNode node which sometimes doesn’t load the node, makes vvvv crash, clears sometimes the connections and some patches are not more editable afterwards. I don’t know if it happens only on my machine…

but not this one? would help us to narrow it down a little, as there are not that many changes from b27 to alpha27.1 but lots of changes between b26 and alpha27.1.

what i can tell from your callstack the error happens upstream of an effect node on one of its mesh/texture/transform inputs. try disconnecting them and see if it goes away. you’ll have to strip your patch down a little and send it to us or i fear we can’t help you any further in this :/

I would really like to do it, but at the moment I’m so busy with my dissertation and with beta26 everything works quite well, except the fullscreen issue on two monitors and a general bader performance in speed and with some geometry and EX9 Texture nodes… But I can live at the moment with it. If I find some time I’ll do some research on isolating the issue and I’ll send you the patch.

Thank you for your help and your patience.

Ciaooo! :)

is there an IOBox (Node) directly above one of your effect nodes? try removing those.

No, I generally don’t use IOBoxes. I always save values inside the nodes to save loading time of the patches (if I’m right)… in the next days if I find some time I’ll do some tests and try reducing the patches.

Just for information. I get the same error on beta27 which I’m getting with alpha27.1 which I don’t get with beta26

00:00:20 * : [mainloop, prepare graph](mainloop, prepare graph) unexpected error: Access violation at address 190AC5A7. Write of address 00000013

if this is an error that is running through TTY all the time please try pressing CTRL+F9 to switch to debug mode and see if any of the nodes in your patch gets orange. if it is a subpatch, step inside it and see which of its nodes is colored orange. like this we may be able to find out which node is throwing this error.

Unfortunately there aren’t any orange nodes in the debug mode and neither red nodes… :(

The error comes everytime I want to change a patch with CreateNode. Then I have to click on Ok (or Hide and Ok) else I can’t do anything in VVVV. It doesn’t repeat in the TTY renderer.

I’m getting also this errors…

00:01:52 ERR : Access violation at address 0040480C in module ‘vvvv.exe’. Read of address FFFFFFFC while Deleting Node of Type DX9Texture (EX9.Texture)
00:02:02 ERR : Access violation at address 0040480C in module ‘vvvv.exe’. Read of address 00000004 while Deleting Node of Type ? (?)
00:02:09 * : [E:\Works\diploma\VI\channel2.v4p, without name (ID: 23)](E:\Works\diploma\VI\channel2.v4p, without name (ID: 23)): Access violation at address 0069260C in module ‘vvvv.exe’. Read of address 00000009

Now I saw something interesting which may cause the error… The patches which I change with CreateNode has the same node ID. Is there a way to change it?

I have two patches with the ID 25.

Unfortunately It wasn’t that, because now I have two different IDs again…

I noticed that it doesn’t have to do with CreatNode, but something with shader fx, but I don’t know at the moment what it is. They all have no errors…

Don’t ask me how and why, but I solved my problem with beta27. I rewrote from zero the patch containing the shaderfx.
But I have still some issues… and something strange does CreateNode in beta27 for me.

Hello devvvvs!

Nice work for the update! The new version seems a lot more faster and has a lot of bug fixes. But I’m still getting this strange error with the latest Alpha 27.1 (20/02) build. It always happens when I’m changing a patch with CreateNode. Sometimes it doesn’t appear and sometimes it does. I don’t have any red nodes and I don’t have orange nodes in debug mode…

00:01:44 * : [mainloop, prepare graph](mainloop, prepare graph) unexpected error: Access violation at address 150C9743. Write of address 000000F6

This is the only error that remained for me…

What could it be?

error.txt (22.3 kB)