Enum pins don't work

I tried to add Enum input pins to a node (I copied this from the SharedTexture node), but when I run vvvv, there is no way for me to change the enum pin, it always stays (for format) ‘No Specific’.

If I try to connect the output of Info (EX9.Texture) to my input pin, the correct input pin is highlighted, insinuating that these 2 could be linked, but the link is broken rightaway, with the folowing tty message

00:27:22 * : tried to connect unmatching pins Info (EX9.Texture).Usage --> ? (?).Usage

This is the code I use for adding the pins:

[Input("Format", EnumName = "TextureFormat")](Input("Format", EnumName = "TextureFormat"))
IDiffSpread<EnumEntry> FFormatEnumIn;
[Input("Usage", EnumName = "TextureUsage")](Input("Usage", EnumName = "TextureUsage"))
IDiffSpread<EnumEntry> FUsageEnumIn;

hei ft,

is this a specific problem with the latest alpha?
also, would you say that on the SharedTexture node the enum pins work as expected only not in your own plugin?


Stupid me, I had 2 pins with the same name,
because I let the old uint pins in there for now.

Would be nice though, if there was a clear message somewhere when you have nodes with multiple inputs with the same name …

Hi Joreg,

I am working in te latest alpha, and the SharedTexture node works as expected, and my own node doesn’t.

I put the dll file somewhere else, and used beta28.1. SharedTexture -> works, my node -> doesn’t work.

So I am probably doing something wrong, but I can’t see what (all my code, except for these pins which you could easily add yourself, is on github if you need to see the whole picture).