Forum

DX11 suddenly shows only black

Perhaps anyone has an idea:
Suddenly dx11 renders only in black. Nothing is shown. No errors in tty, no errors in exception mode. Everything seems running but just shows nothing. In inspector I see even the “Present Time” variating. Everything worked 4 days ago normally. Today I wanted to continue my work and: Only black. The only thing I installed in this time was the unreal engine and duet display. Is it possible, that one of them changes any graphic setup or anything else? I reinstalled vvvv including setup.exe. I reinstalled all graphic drivers. Still the same. It’s driving me nuts. Is there any way to find out what is going wrong here? I know my system (Dell 3800m) is sometimes a bit problematic because of the nvidia optimus implementation. I can choose to run vvvv on the internal or with acceleration from the dedicated graphic card (nvidia M1100). But trying both made no difference. Running on Win10 64bit latest build… last time (and a view versions of vvvv before) I had issues with dx9 and found the solution in disabling “Clip Device” in inspector. Meanwhile this option was unset by defaut. Perhaps we have a similar problem here? Or is there any tool for checking the correct setup?
Thanks a lot for help in advance,
Marf

OK, I restored to a system restore point. It was called “DirectX installed” and was set while Unreal was installed. Now everything works fine again. Even the Unreal Editor is still working. So bw aware if you plan to install the Unreal engine…