Forum

DX11 renderer vs. Windows 8 charms

wow, i didn’t expect this to cause me headaches.

the DX11 renderer in fullscreen-mode allows the windows 8 charms bar to appear with touch input. this is quite a killer for kiosk-type touch applications (as you can access the start menu, …).

what are the options to avoid this situation? (EX9 renderer does not show this behaviour btw…)

thanks for any hints!

shared texture dx11 -> dx9 -> fullscreen.
dx11 fullscreen isn’t real fullscreen yet

aye woei, that might help.

i also found another brute-force solution: kill the windows explorer. not what i consider ideal (workflow-wise), but it works ;)

@motzi…nice idea :)

haha, nice one indeed!

also forcing the focus to stay on the render window might work. SendMessage (Windows) with MessageCode 7

a nice shortcut kill the explorer manually is:

  • right click task bar while holding ctrl+shift
  • select Exit Explorer

to restart explorer again

  • bring up task manager, e.g. by ctrl+shift+escape
  • menu: file -> run new task
  • enter “explorer”

For me, Woeis solution works without noticable performance drawbacks. It also fixes a stupid Vsync-Problem that I have on a dualscreen-Setup with DX11-Renderer in Fullscreen!
(I know, this seems to be a Windows-Problem, but having DX9 in Fullscreen fixed the Vsync, so no tearing in animations anymore) :)

for the record: http://www.tenforums.com/tutorials/48507-edge-swipe-screen-enable-disable-windows-10-a.html