Forum

DX11 performance issues

I am in the process of (finally) making the transition dx9 to 11 and was looking forward today to see my 2nd dx11 work on a big screen (three of them, actually) on a really beefy computer…

… and the moment I did as much as setting a DX11 Renderer to fullscreen (or just enlargen it), the framerate dropped to 30, 2nd and 3rd Renderer brought it to <20. I noticed this first with the actual patch (temptarget to 3 quads to Renderer(s)) and assumed it was an error on my end; but then I got the same problem in an otherwise empty patch.

Didn’t have any ex9 example to really test performance but I did throw alot! of things in a FlockingBehaviour at the machine without it breaking a sweat at 1920x3600.

Happened with 33.7. Couldn’t test 34.1.

i’d the use latest versions first (vvvv and dx11). if it’s still happening, you should share your patch and pc specs.

Well, I even had significant slowdowns when pushing my renderer to the secondary display. Only accomplished smooth fps on my primary display. Maybe hidden renderers/temptargets would still be running on the primary head and swapped onto the secondary?
Also experienced quite noticable slowdowns when having a couple of renderers visible for debugging. Hiding all but one would set my fps back to full speed.

hi, u can try to set ur second screen as primary.
From ur description looks like u have some issues in pipeline…
u can try query nodes to see what ur timestamp and where.
most cases second screen don’t count, weather u got some shader that goes crazy or node u have to delete and do ctrl-z

I’ve found that multiple dx11 renderers run slower than dx9, even when there is nothing rendering in there. I tried to transition a project using 3 renders (2x1920 x2 and 3x1920) dx11 was down to 40fps, dx9 solid 60+

are u guys on resent dx11 builds?
to be honest vvvv itself is super slow compare to unreal engine on my taste

I have tested that on recent builds, this was last spring I think, buts its going to be slower than unreal!!

@ catweasel, precisely. It wasn’t a matter of my patch. Same thing with literally only the Renderer Node (and Timing). I also tried the latest version (that is, what microdee suggests for the vvorkshops)…

On the other hand, the machine I had, despite being “beefy” couldn’t care less about the actual creation of GFX so after all, not a surprise that things didn’t run as smoothly as I hoped.

@guest:

Check if you have a depth buffer enabled in your Renderer (DX11). There was an issue with enum (fixed in git already), as it seems you exactly have that problem.

In the meantime render your scene to a temptarget renderer and use a constant pass to draw the texture.

@catweasel:

Do you use several graphics cards?
Never had problems with 3 renders (or more) on same card.
Also check about that depth buffer thing :)

It was 2 eye finity cards using a total of 7 outputs + patch screen. Depth buffer would have been on. I think I saw it just by creating the renderers not even assigning them to outputs or full screening them.
My eyefinity isn’t setup at the moment, I’ll try it again when I can

I have a dx11 project with similar multi renderer problems. Odd ones too -

The patch has various rendering and post processing shenanigans going on. If I have no final renderer, the fps is around 40. If I add 1, 2, or 3 renderers the fps stays at 40, then if I add 4 or more, it drops to 25fps.

The odd thing is, these renderers don’t even need to be connected to anything. Just by making the 4th one the framerate drops.

Has anyone else encountered this? I’m using latest beta x64 and latest dx11 from contributions