Dx11 pack stops beta5 from starting up

added the 1.0.1 x64 pack to a clean install of beta5 and v4 wont start anymore.
remove the pack and it works again.
github report

not sure if related. happend today, but no time to investigte further
on a machine with 45beta34.2. but no problems on an other…
and it will start after some time, it just takes ages…
will backcheck tomorrow with old ver…

Betta takes me ages to load also, about 5 fucking min’s LOL
2017.02.10-13.43.50.log (2.3 KB)

not sure if it would solve the 5min delay but the idea is that a pack would contain a nodelist.xml so that vvvv does not have to parse the directory but can simply rely on the info in the nodelist.xml and typically this reduces startup-time.

@vux is there a reason you’re not adding one for the dx11 pack?
here is how: https://vvvv.org/documentation/nodelist-(vvvv)

@joreg :
Yes, since I did check boot times previously, and using nodelist.xml on dx11 pack did not provide any improvement on startup time.

I’m on investigating this further… so clean betta, nothing fancy, all previous pack’s copied from the one that starts 5 mins startup time only 20 seconds…
Played a bit with dynamic plugin, now again betta takes ages to load… any suggestions?
Think this might be reproducible…

hei @antokhio please try to provide a step-by-step guide to reproducing this to allow @vux or us to investigate this further.

As a side note, from our tests, beta35 lite (eg: with vl removed) works as expected.

@vux with your tests, did you find a way to reproduce described behavior that you can share?

allright i was investigating this issue further and i think i know what causing it:
On win10 go to Windows Defender go to Settings add vvvv folder to exception, startup time 2 seconds!

Was looking on taskmanger and found an AntiMaleWare process taking 50% of CPU whenever vvvv is launching.

please report if that helps

1 Like

It helped me 👍

Good to hear, hoping for more positive responses to push that to download page wiki ;]
btw @ggml is it helped you?

also i added all places i store vvvv folders and vvvv.exe to exception processes

confirmed! thanks antokhio

Yep, freaking Defender is guilty

so @joreg i guess we can push that to wiki

great find. i added it as first entry on the troubleshooting page: https://vvvv.org/documentation/troubleshooting thanks for digging this up!

sorry for late,
seems like initial issue was different,

tried this:

b32.4 x64 with 0.7.1 x64 (attached logstartup)
b35.1 x64 with 1.0.1 x64
b35.2 x86 with 1.0.1 x86 (attached logstartup) (tried rename lib/packs)
b35.2 x64 with 1.0.1 x64 (attached logstartup) (tried rename lib/packs)
none worked with dx11 pack folder inside, all worked without it

all logstartups say “exception occurred while trying to create an instance of type ‘VVVV.DX11.Factories.DX11NodesFactory’.”

(b32.4 x64) 2017.03.21-19.31.58.log (3.5 KB)
(b35.2 x64) 2017.03.21-18.59.27.log (3.5 KB)
(35.2 x86) 2017.03.21-19.14.34.log (3.5 KB)

any idea about what software might interfere in this case ?

If you are sure that your beta and dx11 pack are downloaded without corrupted files, then prolly a windows corrupted, i remember old times i had to reinstall .net Framework to make vvvv work. Your best bet try another machine, if dosen’t work try download clean beta, clean pack. Then try Framework reinstall, VC redist reinstall, windows reinstall…

also try different folders… c:\ might have restrictions, similar to /programs folder.
also re-download the dx11 pack, might be a corrupted dll. from the log, the problem comes from loading the first dx11 dll which is not a problem for other people, so it has to do something with your machine…