Forum

DX11 IndexedGeometryBuffer

I tried to create a spread of meshes with the DX11. Seems it is not working as expected. In the patch I would expect a cyan quad and a red triangle, however the triangle is a quad as well.

Am I doing something wrong or is this a genuine spreading bug of the node?

IndexedGeometryBuffer (DX11.Geometry Join) help.v4p (19.8 kB)

I think it should works now

IndexedGeometryBuffer modif.v4p (21.6 kB)

after vux confirmed, that his node simply does not support spreading i started coding my own. maybe it helps someone

edit: code got contributed

wouldn’t that make a nice pullrequest at https://github.com/mrvux/dx11-vvvv then?

Does anyone have a compiled version of this? Does not seem the to have made it in to the b32 dx11 release.

Or does it work as dynamic? Perhaps the references just need to be updated?

Just checked and got it in my nodelist here.

Ah yes, was just typing the name wrong. Thanks chaps!

Where can I find it? I use dx11 b33x x64. Or isn’t the 64bit version updated.
Shouldn’t the example file of velcrome be working if I change the vertices list of the second mesh to start at 0.

IndexedGeometryBuffer (DX11.Geometry Join) again.v4p (19.9 kB)

it’s quite tricky.
copy paste in new Template (Value) node
then u need to resolve depedencies
ctl-j, references, add feraltic…

type of namespace DX11AbstractMeshNode not found

public class MeshJoinNode : DX11AbstractMeshNode, IPluginEvaluate

just to clarify, this node has been part of the dx11 pack ever since november’13, of course in both x86 and x64. it is not necessary to dynamically compile it.

it got retagged in october 2014, but that should not matter much.

as for the original question, IndexedGeometryBuffer is still not spreadable as of today