Duration Timeline (OSC)

Thanks to DieTapete´s shout I found this nice new tool called Duration.


Download (02/2013):


I tried to build some example receiver in v4 (wanted hard links, no todo-map), it works reasonable well in 28.3 but some parameters jump in a strange way. I believe this is due to my limited patching skills. ;-)

In 29.x I get pretty jittery motion and don´t know why.

In the moment its one way comm, I did not build anything to send OSC data to Duration. Anyhow, it might be some start for others.

How to get it working:

-open duration_timeline_help.v4p
-startup Duration
-Press button top left, choosen “Open Project”,
-navigate to the place where you exctracted “vvvv_test1” folder
-hit run

Duration_Timeline1.rar (11.5 kB)

Great work, the guys from Telenoika show me the tools 1 weak ago, but i didt try it to vvvv, i see that you did it work just fine! :)

im still getting a application error if i try to add a mp3 track, its the same for you there?

James George http://www.jamesgeorge.org/ is a very talented and generous programmer.

Thanks for the info, good stuff!

does it have undo? :)

… and if you encounter value jumps, check the string encodings.

Hehe, yes Tonfilm, I believe it does!

@vjc4 I did not try to add a MP3, but WAV seems to play fine. (using Duration_003)

@metrowave Thanks for the hint, looks pretty much like Duration is a compiled version of ofxTimeline. https://github.com/YCAMInterLab/ofxTimeline

@tonfilm Yes, CTRL-Z is working, you can even revert multiple times. The only things I miss is proper bezier handles.

I looked into my receiver patch again and could pretty much track down the problem. I focused on the value “amount1” since it is linked to rotation in my help patch and the glitches are obvious here. Found out that if I only send the “amount1” track it is received fine. If I also turn on “send osc” for “X1” the value of this track gets copied over to the “amount1” value.

This only happens if I try to extract by feeding my OSCDecoder with a spread of strings, a second one which only gets a single string decodes fine (see picture).

Dunno if there is a bug in my logic or if its in vvvv. (Running custom 28.3alpha I got from Elias & Elliot, so I can get the kinect stuff working. THX again for this !!!)

Yes it looks very nice,
but the time code it sends is not precise enough to play an image sequence.

Tonfilm we are still missing a modern timeliner integrated on vvvv, with undo and a reliable clock, to be used in boygroup scenario.

There is a way to receive the timecode itself? How can I enable it?
Have you tried to set /duration/oscrate to a higher value?

Sory for hijacking: Meierhans, please send me an email, or add me on skype, we need to talk. ;)

@Westbam I just added you to my skype.

@Westbam I just added you to my skype.