Forum

DirectXRenderer problem

flatscher wrote:

Ich hätte betreffend VVVV nur ganz kurz eine Frage zum DirectXRenderer. Nachdem es bei mir bei der ersten Installation zu einer Fehlermeldung betreffend einer gewissen d3d9.dll Datei kam, installierte ich nach einer kurzen Google-Suche nach möglichen Fehlerbehebungen die neueste DirectX Version 9.c auf meinem Rechner, worauf die V4 Installation dann problemlos möglich war. Nachdem ich dann die 6 Einsteiger-Tutorials auf der Meso Seite, welche alle den Renderer (GDI) verwenden, beendet hatte, habe ich mir ein paar Patches im Girlpower Ordner angeschaut, wobei ich leider feststellen musste, dass bei Patches mit dem DirectX Renderer kein Ergebnis/keine Reaktion zu sehen ist, beim z.B. “bezier”-patch aus dem Girlpower Ordner (verwendet Renderer (GDI)) aber sehr wohl doch. Wo könnte da eventuell der Fehler liegen?

what graphics card are you using? do you use the newest graphic card drivers? DirectX functionality will not be available if the graphic card does not support it…

i’m working with a “hp omnibook xe4100 laptop”, sadly already 4 years old, with a graphic card called “S3 Graphics TwisterT HP”, that’s what my hardware manager says. mhm, doesn’t sound like a ‘high performance’ graphic card to me. furthermore i wasn’t able to find any new drivers for this old tool. any suggestions?

you could try creating a Device (Auto) node and change vertexprocessing to software (using an inspektor).

actually that should happen automatically internally…but maybe there is a problem with this code. are you using beta9.10?

…okay, first i should maybe say, that i’m really really new in this whole vvvv-thing. i downloaded the beta 9.10 version just a few days ago. i tried the 6 “rookie-tutorials”, which are dealing with the GDI renderer, and everything went fine. after that i had a few looks in the downloaded program folder to try some patches from the girlpower folder, which are mostly working with the directx renderer (ex9). but sadly, i couldn’t recognize any results in the patch. in contrast to this, there had been shown “a result” in the “bezier”-patch, which is using the GDI renderer, for example. so, could it be, that my above mentioned graphic card is the reason for the not-working grey directx render(er) window, or do i have to push something like a start/go button ;-)? and, if i create this device (auto) node and change the vertexprocessing to software, to which node do i have to connect it? or do i have to create the device (auto) node instead of another node in the patch and replace it? i really have no idea what to do… :-(

…oh. wow. i cannot believe it. i actually really found a driver update for my lousy graphic card (indeed: “END OF SUPPORT ANNOUNCEMENT! S3 Graphics has ceased manufacture and sale of this product. S3 Graphics will no longer provide drivers for new operating systems or any other support for these devices. The drivers provided below are the latest versions and will not be updated.”) and which surprise, it’s really working now with the direct x renderer, altough the driver update-date lays back 2 1/2 years!! so now, looks like the vvvv-fun can begin. and of course, thanks for your suggestions anyway. greets/c.