Destroyed patches

hi vvvvolks ;)

strange things happened here…

when i open my patches in beta20/21 always the render-windows appears - but the patch windows are “hidden”…

patch works but i cant see the patch window.
pressing STRG+TAB the patch-window (it should appear on top in the list, isnt?) is there - but withous a name (there are 2 empty fields on top - then the render-windows appears)

minimize vvvv and restoring seems, that the patch window goes to the middle and gets 1px small…

strange thing - it is in all my patches and worked perfect till last week…

i´m on a vista x64-environment

any ideas to restore my patches?
thanks ahead

little update

copied the patch and the whole vvvv-directory to another pc (xp based) - works fine!
so - i think - the problem is not inside vvvv. any ideas? ;)

did you by any chance install 3d studio max recently?

hi joreg,
thanks for replay and sorry about delay

i know that post - and YES i have 3d studio max installed --> LONG TIME AGO

both “installs” are older than a month. AND vvvv worked very well till last week. there’s no change on my system…

if i start a new patch - everything works fine - i see the patch window and everythings works as usual…

only my “older” project files doesnt work anymore on only that 1 pc…

i had the same problem on an dell laptop, running vista and NO 3dsmax installed…

maybe any shortcut/trick i dont know? do you need further info?


sounds a little like that Vista problem. Did you try DX9.0c version mentioned in this thread?


if you have some patches opening it is definitely not the 3dsmax problem…ahm…strange.

when you open the patch in a text editor you see its xml description. there the first BOUNDS tag has top and left attributes you could check. take the values divided by 15 to get the value in pixels. you could also change those to 0 and see if the patch opens then…


frank: have directx9.0c and slimDX installed… as i mentioned, when i start over a new project - all windows are there and everything works fine (also the demo in arg.txt)

tried your hint. my first thoughts was also about the resolution… but - i copied a “header” from an working file to my patch… doesnt work - nothing changed :(
setting top & left to 0 doesnt work…

the funny thing is: in this patch are subpatches - if i open the subpatches seperately - they work!

damn… any other tricks i can try? ;)

the funny thing is, that the patch is working. i see everything in the render-window correctly…

thanks ahead ;)


can you post such a bugging patch here?

damn, I’m sure i had this once. don’t remember why. i think it was again any freeware i installed.

what happens if you create a new patch?
visible or not?


i can post this patch - but it will work on your system. as i told, i copied the whole patch + my vvvv-folder to an other pc - works perfect…

if i create an new patch or open any file from helpfolder or so - everything works fine!!

i think, it is a vista problem, because that that error occours 2 times (on 2 pcs) - both with vista…

but i never noticed that kind of error in other software - and i work with vista every day more than 1 year.

if it helps - i can send my patches to you…


really strange. if you post a patch i could at least try to replicate the problem on my vistamachine…

same problem as mie, but can anyone tell me how to open a new patch to do the documentations? It´s the first time I try to open vvvv and unfortunately it doesn´t work.

Clicking the tab at the bottom line also on my vista machine it seems as the window is only 1 pix small…well it´s not there…only the arcs-file…

best Milian

some news from here…

i have found the reason for all that trouble by accident…

i have some freeframe effects in my patch - and these are the cause for the problem - as soon as i rename the .dlls - everything works fine!!

especially these 2 freeframe effects causes the same error on ALL VISTA machines:

ExposureThreshold by Syzygy
DelayChannels.dll (no idea, wheres this from)
and sometimes ScrollingStrip.dll

is this a well-known problem or sth new?

hope to help / get help ;)

cheers // grobkorn


never heard of. probably not too many people are using exactly those freeframes and vista? other freeframes don’t cause that trouble, ja?

hi joreg,

yes and no ;)

most freeframe effects are working fine - some of them cause a crash of vvvv - they simply close all vvvv-windows.

i use vvvv as a vj - so i like these “old” relicts from “resolume”… so i cant give up these possibilities ;)

but… i can live with this “failure” as long as i know which fffx causes trouble (and delete them from my directory)

if you want - i can send these fffx to you for testing…


mm…actually if you can live without them…and nobody else cares…i’d rather go for some icecream than looking into this…

lol - ok. lass´et dir schmecke ;)