Forum

"delay" node bug

hello,

in 31.2 32bit a “bang” after “delay” dosn’t works proper.

greets
lca

Hello, try a TogEdge (Animation) between Delay and Bang.
Every value >0.5 = true = 1; try attached patch, and then put a TogEdge between delay and bang.

lca_delay (6.0 kB)

delay and bangs are a bad combination since the delay time might fall “between” two frames and thus not get through at all.

to counter this, you can either have one constant value that changes with the incoming bang and then detect that change after the delay using change. alternatively and I prefer this method is to use monoflop followed by togedge using the down edge to get the outgoing bang.

Hi sunep could please you post a patch explaining this

“you can either have one constant value that changes with the incoming bang and then detect that change after the delay using change”

Thank you

Just tried sunep´s advice but i see strange bahaviour,
like the change bangs twice after the delay.

bang->toggle->delay->change->counter
(the counter counts 2 for one bang at the beginnig of that chain)

please see the attached patch.
why is that so?

delaybang.v4p (9.1 kB)

In your case, I think that your problem can be solved by setting your delay node to Point mode it does not resample.

I have attached a little example of how to delay Bangs using the methods I described above.

DelayedBang.v4p (15.4 kB)

ay, thank you for the explain and for pointig out the mode selector.
will use more caution with delay in the future