Decklink VideoIn low perf issue


Is it normal that receiving a 4k stream with VL.Devices.DeckLink eats that much resource (using 2021.4.9 - 952) ?


For reference with full HD :


I’m planning to use this 4k stream to pipet a lot of pixels and was wondering it’s normal that “just” receiving a 4k stream eats that much.


This is certainly not normal…
Could you give us some info about which vvvv and nuget package version you are using?
Did you enable “Do Convert On GPU” on the VideoIn node?
Does it behave the same if you remove the IOBox in the patch and use a FullScreenQuadRenderer in a SceneWindow?

Thank you for the quick reply.
I took the latest preview (2021.4.9 - 952) and I download the Decklink nuget today (but it seems it didn’t change for quite a while.)
Having the iobox or nothing plugged on it doesn’t change anything.
I tried with and without the GPU option.
Thanks to Seb Escudie, We obtain better results surrounding with an Asyncloop region the node.

Thank you

do you know in what kind of mode the capture card is in? like format, fps, and such things? we’ll have a look at the code in the nuget…

It was a 2160p25. Can’t remember the color precisely. Yuv 8bit ithink. I could confirm Wednesday.

Thank you

The node was written in a way that it will wait for each camera frame (that was a project requirement back then). So say your camera has 25FPS, timings like 1.000.000/25 = 40.000µs = 40ms should be normal.

I also remember that the GPU option wasn’t producing the correct results, so could be that it’s switched off currently. Can have another look at the node in ~1-2 weeks when back in the office.

“will wait for each camera frame”
exactly : it’s why it’s working better once in the Asyncloop.
I’ll try more tomorrow.
Thank you

Hey there,

Seeing weird timings on the DeckLink VideoIn node. When enabling Convert on GPU, for some time timings look ok :


But after “a while” (say one or two minutes), timings go up.


Any hints? Thanksthanks

edit When pressing F9, timings go back to ~3µs and then go up again.
edit 2 Turns out Convert on GPU gives a jaggy texture. We’ve tried to disable it : the texture has better quality, but the Timings behavior described above still occurs

That one is supposed to be fixed see: Convert on GPU leads to artifacts · Issue #5 · vvvv/VL.Devices.DeckLink · GitHub

Concerning the timing see @Elias post above

1 Like

Yep, I see. Was just wondering why would timings be fine for a few minutes and suddenly blow up.

Hey, just tried receiving a 4k video input and instantly got a massive leak.

I’m receiving a 4k stream. When the Display Mode is set to 1080p30, I can still see a texture though it has a massive delay. When I switch it to 4k2160p60 (which is what the DeckLink is actually receiving), memory usage starts growing and never stops (this is what you see on my screenshot)

And it doesn’t leak in lower resolutions?

Nope, does not. All is fine when receiving Full HD

Now that we have a local setup again, started to look into it but so far can’t reproduce what you’re describing.

Our setup here is a DeckLink Mini Recorder 4K, which we feed via HDMI from another machine with a 4K@30 signal. Now here I see two differences from your setup:

  1. It’s probably not a YUV signal, therefor the converter doesn’t need to run
  2. It’s 30FPS and not 60FPS, our device doesn’t support 60

Can you tell us more about your setup?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.