Forum

Correctly layering images with transparent areas in front of a 3D mesh

Hi guys,

I have a 3D scene in which I’m trying to layer a few objects.

There is a 3D mesh imported using XFile (white) sitting in front of a background image (green).
I then want to layer another image in front of the mesh (red) - this has areas that are completely transparent and should show the mesh behind.

The image below is a top-down/bird’s-eye view of the scene:

I’ve tried changing all the properties of the Renderer (EX9) but I still have a problem with the transparent parts of the image closest to the camera (red). They either appear

  • black (and so block out anything behind) or
  • transparent (but for some reason block the white 3D mesh being rendered - i.e. only the green background can be seen).

Does anybody know anything I could try?
Any help would be awesome… thanks as always!

yea u need to connect layers in group in another order prolly, first shud be rendered background, then ur white mesh, then transparent layer

ZWriteEnable (EX9.RenderState) with ZWrite Enable set to 0 on the transparent layer should do it. and the transparent one has to be the last input on the Group (EX9) (right side)

Thanks very much for the replies @antokhio)) and ((user:woei!

Managed to find a solution - the problem was related to the group node. I did have the layers in the correct order, but I changed it to a group priority node and for some reason it works now!

Great, I’ll give that ZWriteEnable node a try - thanks again for your help guys, much appreciated!