Forum

Connections missing

Weird bug and not reproducable, but this time I remember it:
It happend, that I was looking for the bad part in my patch, why I couldnt get my values I needed. Actually it worked the day before.
So I was opening one subpatch after the other and suddenly the values were running. They werent before. I closed this subpatch and it stopped again.
I was going with my mouse pointer over a output pin of subpatch to check why and it was running again.
After that I opened this subpatch (running again) and stored it as a tab (which is like open) and it worked properly all the time.
For me it looks like there is something going wrong, if its not in active, visible gui-mode.

Something similar happens before, but always by accident and in no logical order. So sometimes connection were not established internal, but connected by a line at gui-mode. If I deleted this line and connected again, then it was running properly. Im not sure if this happens, if I open a patch or if its a patch done by an older version.

Even so, sometimes I can connect a node with to lines at input pin. Obviously one is not connected internal, but at visible mode.

This is in version 16, but happend in 15 too.

I hope it isnt sounding too weird, but its like that.

Yes, here too many weird connection bugs(>beta14)…Like using Undo, deleted nodes and connections won’t reappear(until saving, closing, reopening the patch) but are running…And i saw this 2 connection weirdness too…

right, there seem to be troubles related to the currently broken undo.

the double connections to inputs are a different, but also a known problem.

thanks for pointing those out. we’re at it.