Compiling FiducialTracker -> headache

hi there,

i’m just getting a headache trying to recompile the FiducialTracker (DShow9) because i need another set of fiducials than the one provided hard coded in the header file.

unfortunately i’m always ending up in this error (like @nobusdeer)) ((forum:freeframe-for-vvvv-dont-build):

mingw32-g++.exe: error: unrecognized command line option '--add-stdcall-alias'
mingw32-g++.exe: error: unrecognized command line option '--input-def'
Process terminated with status 1 (0 minutes, 6 seconds)
0 errors, 0 warnings

i tried using codeblock 13.12 and 8.02 with their respective MinGW versions - without any success (same error). apparently these compiler options are not supported any more. googling did not help much either…

what’s nescessary to get a working freeframe environment?
joreg maybe?

hmm, this seems to fix at least the first error (–add-stdcall-alias):

still, the linker is not happy with --input-def

wow, this seems like time-travelling:,4351.0/nowap.html

here a mysterious “iorec” was struggeling with similar things :)

this seems to work for the linker settings.
edit: (Menu)Project -> Build Options -> Linker Settings -> Other linker options

-Xlinker --add-stdcall-alias

at least i got a dll now. now let’s see if it works properly…

wow, thats been ages…
iirc the --input-def has to do with the
file which somehow specifies which functions of the .dll will be exposed.

no idea…see if it compiles and creates a .dll without that flag. just to make sure there is not other error.
still then probably the .dll probably won’t work because you somehow have to tell it which function to expose. and i can’t help you with that but maybe it can be googled.

or also see if you can get hold of a more recent working freeframe template project from the official freeframe sources. and compare with that?!

well, the above mentioned solution seems to work. i’ve had it running for a few hours with the updated 1.5.1 version of libfidtrack and an alternative set of markers, without any problems. but i would not call this intensive testing…

great find. please make sure to pullrequest your change so it is saved for the future.