Forum

Christmas pack 2011 slow kinect

I just played around with the new kinect nodes in Vuxens christmas pack.

It seems to work just nice but when starting the skeleton help patch, the patch runs at 60fps but the skeleton updates with several seconds inbetween.

the depth and RGB textures run at what seems to be full speed.

-sunep

Ok after having a look, skeleton is fine but enabling depth videostream slows it down a lot.

If you enbable skeleton only (remove color/depth in Kinect main node can you confirm that speed is fine?.

Thanks

Vux

Hi!
Sorry, I’ve tried it (if I understood you correctly), but it doesn’t work for me.
If I set “depth mode” to “disabled” in the skeleton help patch, it still runs very slowly, and if I uncheck “enable color”, it doesn’t work at all and the “is started”-box gets empty.

But thanks a lot for the whole kinect thing, got one for christmas so timing was great ;-)

I’m getting a similar issue with my kinect, b27, running on bootcamp macbook pro. The depth is very slow to update, however the RGB is lightning fast (although it does give a corrupt image every 30 frames or so). Can’t get round it at the moment.

Kinect works fine with b26, openNi_1.1. Now with 27 and OpenNI_1.2, depth is super slow. Any help appreciated. Thanks.

Try setting your mainloop to 30fps. This fixed all my skeleton problems.

Jon

After more tests seems the .net wrapper is pretty slow (videostream events).

Reworking wrapper to mixed mode so should be updated on git shortly.