Changing Setups with multiple FileStreams

Hello there,

I’m having a problem with multiple setups, and I believe, that it’s got something to do, with FileStream. I’m very new to vvvv, and I hope, you got a solution for it.

For a theatre performance I need to project on six walls and the floor - a total of 7 quads, with varying sizes. In each scene (36 in total), the positions of the quads change, and the content that ist projected onto them too.

So I made subpatches for each scene with 7 quads and their transformes grouped together. To blend gradually between the scenes, all quads were given a common alpha value, which I can slide up or down from a different control-subpatch.

In the main-patch, all the scene-patches are being grouped, and then piped into a renderer.

Whatever I do, vvvv reacts somehow unpredictable. At some point, I couldn’t load any new files into filestream nodes - the file-open dialogue wouldn’t even open. Some videos wouldn’t start, some would. I thought, that the problem is, that all the videos (not much less that 36x7 filestreams) run at once, so I added a disable-switch for all subpatch-groups that were not in use. Still the same problem: in some scenes the videos don’t start. Videos that have started before, and that I have changed in my video-editing-software, don’t start anymore (btw I’m using wmv-codec).

Usually the quads, that have a static simple filetexture work fine.

I decided to try if it ware just too many nodes, and splittet the setup. With half the subpatches it doesn’t work either.

Now I’m pretty lost, and I hope you have an idea, what I could try to change.



PS: I could paste the patches, but they’re messy and maybe not of use without the video-files

I forgot to say, that the problem is persistent with both, filestream2 and filestream, and also with the different video-texture-nodes

Right now I found out, that deleting the videotexture-node and re-creating it, helps. Still the whole thing is unstable.

Have you tried vlc?
Maybe can help. And would you please report?

I’ve tried to install the VLC-Plugin, but I can’t get it to work. I’ve cxopied all the files into the directory and created a textfile with the search-path. The VLC-Node is red, and vvvv crashes.

Here’s working. Try to install VLC, then download and save to contributions folder the unzipped vlc05test beta27.1 and substitute vlc0_5.dll with latest release (

Hope it helps.

Okay. The VLC-Problem is solved. I realised, that I had two installations of VLC running, a 32bit and 64bit one. That seemed to confuse vvvv. I am about to do some patching today, and will see, if the problems are gone.

Hello there,

The problem ist still there. I changed all the FileStream/Videotextures in the subpatch for the scenes. Now vvvv crashes instantly when loading the subpatch, and I can’t even test, if the videos would be played.

It’s a c+±runtime-error I get, saying “This application has requested the runtime to terminate it in an unusual way. Please contact the applications support-team…”

I’ve added the patch, maybe someone can reproduce the crash.

szene5b_beam01__.v4p (50.0 kB)