Can't use shaders from nvidia

Hello. On my first encounter with shaders, I decided to load some premade from nvidia and ati libraries. Although I can load them in my patch, they don’t show anything. The basic setup is: teapot->cage->renderer. The same connection works when I use the vvvv native (ex.gouraud directional)shaders. Note that this is a very basic shader with no need for textures.

firstShader.v4p (3.2 kB)

please send us the .fx file bundled with the patch in a zip file.

I found that quite often you have to go through and delete stuff in them, follow the error hints, Although sometimes its hard to know why!

Nvidia shaders without .fxh associated files should work.For the others you have to implement the called fxh functions into the shader…I think in ure case, the cage fx has a .fxh file associated that can’t be load… so i tried to do it…as an exercise!

PS: don’t know for ati’s…never tried yet. (6.9 kB)

yours work properly desaxismundi, however it doesnt render as shown in nvidia’s images. my cage shader has only one file which is cage.fx. I chose this shader especially because it did not require a texture (i guess). so here is mine which doesn’t work.
btw, your cage is a little bit different than mine desaxismundi, did you download it from nvidia? (2.6 kB)

Yeah its nvidia one…here tha shader a little bit cleaned up… (5.6 kB)

Hey buraque,
just have a look at ure shader and, of course, mine is different because, as i said, there is a joined .fxh file for the procedural texture function called stripe_tex.fxh…(supposed to be there when downloading the shader from nvidia)…this shader works with procedural texturing…so u need a texture…

Hope it helps,

thankx desaxismundi. now i get it.