Can't run exported app with 2023.5.2


I exported a project with stable Gamma 2023.5.2 and the exporter shows no error:

Nevertheless, when I try to run the .exe, the application never opens.
I checked the task manager, and I can see the application (AESPark_ThermoCenter.exe) popping up, but then being killed instantly automatically…

Task Manager 2023-09-04 19-04-58(1)

Also, the exported folder looks weird to me, compared to previous exported app. Where’s the data folder?


Tried on another machine → same result.
Updated Dependencies mentioned here and rebooted → same result
Ran as admin → same result

But all the other exports I did with the exact same Gamma version and computer are working correctly.

Is there a way to figure out what’s wrong with that specific export?

Thanks !

Set the vvvv editor to Pause on Error and make sure the patch doesn’t stop when started (errors / pink nodes).


I already have Pause on Error enabled, also with Jump to Error.
But my project is running correctly with vvvv opened: no red, purple or yellow nodes, no error detected on startup, no pause, nothing. It runs smoothly with the editor.
This issue only happens when I export it, and try to run the executable.

Is there anything in Windows’ Event Viewer about your app crashing on startup?


Ah yes, true, I forgot to check Windows Event Viewer !
Thank you for the reminder !

So, you are right, I do have error logged in Windows Event Viewer:

  1. Error with source .NET Runtime says:
Application: AESPark_ThermoCenter.exe
CoreCLR Version: 6.0.2123.36311
.NET Version: 6.0.21
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeInitializationException: The type initializer for '<Module>' threw an exception.
 ---> System.TypeInitializationException: The type initializer for '<Module>' threw an exception.
 ---> System.TypeInitializationException: The type initializer for '<Module>' threw an exception.
 ---> System.TypeInitializationException: The type initializer for '<Module>' threw an exception.
 ---> System.TypeInitializationException: The type initializer for '<Module>' threw an exception.
 ---> System.InvalidOperationException: Could not load native library libbulletc using CPU architecture x64.
   at Stride.Core.NativeLibraryHelper.PreloadLibrary(String libraryName, Type owner)
   at Stride.Engine.Module.Initialize()
   at .cctor()
   --- End of inner exception stack trace ---
   at Stride.Core.DataSerializers.VL_Stride_RuntimeSerializerFactory.Initialize()
   at .cctor()
   --- End of inner exception stack trace ---
   at Stride.Core.DataSerializers.VL_AESPark_Lib_vlSerializerFactory.Initialize()
   at .cctor()
   --- End of inner exception stack trace ---
   at Stride.Core.DataSerializers._0_Context_vlSerializerFactory.Initialize()
   at .cctor()
   --- End of inner exception stack trace ---
   at Stride.Core.DataSerializers.AESPark_ThermoCenterSerializerFactory.Initialize()
   at .cctor()
   --- End of inner exception stack trace ---
  1. Error with source Application Error says:
Faulting application name: AESPark_ThermoCenter.exe, version:, time stamp: 0x641cef7e
Faulting module name: KERNELBASE.dll, version: 10.0.19041.3324, time stamp: 0x6967c799
Exception code: 0xe0434352
Fault offset: 0x000000000002cf19
Faulting process id: 0x3ab4
Faulting application start time: 0x01d9dfd2261158f2
Faulting application path: C:\Studio Brüll\x\export\AESPark_ThermoCenter\AESPark_ThermoCenter.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: d05b0f87-b2db-4473-9262-284e959eb2db
Faulting package full name: 
Faulting package-relative application ID:

Looks like it is related to Stride from the 1st error.
I’m using a custom VL.Stride made by Tebjan for this project.
Maybe it is related?

Hmm, it starts to become very blurry to me now.

I read on some forum posts that the second error (Application Error) could be related to an exception not being caught properly. And in my case, it seems that exception happens on startup. But I couldn’t find a way to point it out and figure out what is wrong.

I even tried to surround my complete project with a Try region: no error with the Editor, can export, but still can’t execute the .exe. So, same result so far.

I also opened the solution in Visual Studio. When I open it, it says no error, just some warnings, but nothing that could compromise anything in my opinion. If I Debug in VS2022, it builds the solution but then when it starts the built project, it fails with this error:

Exception thrown: 'System.TypeInitializationException' in VL.AESPark.Lib.vl.dll
The program '[23108] AESPark_ThermoCenter.exe' has exited with code 3762504530 (0xe0434352).

I tried to check that mentioned VL file, but can’t find anything wrong.
Moreover, I use that exact same file in another exported project, and that one runs correctly.
And of course, if I removed that file from my current project, the error is then transferred to another VL file…

It’s really unclear to me what’s happening with that exported application.

Anybody encountered something similar already?
Or do someone has hint on what to do?

Delete parts of your patch, export, check if it works. Repeat. I’d do it from bottom up (in your case first remove the view, then the controller for example). If it starts working when one of the “major” patches was removed, re-add that and then start removing only parts of it.

Alright, that’s exactly what I started to do today, but stopped because that was long and repetitive.
But if this is the only solution, so be it.
Thanks :)

The other option is always to go the priority support route, where we can look at your projects together and help debug such issues. If you’re interested, please get in touch via or contact me on the chat.