Forum

Can't get Unicode to work

Hello,

I can’t get Unicode to work. Non ASCII characters are wrong both in IOboxes and in rendered output. I get lots of empty squares, capital As and probably other garbage instead of non ASCII characters, with encoding set to UTF8 and fonts set to Arial Unicode MS, or Tahoma, etc.

I get this with the bundled examples UniStart.v4p and Unicode.v4p as well.

Could this be related to Windows locale / version / settings? I have a Hungarian Vista with the English language pack, so my UI is (mostly) in English. The locale setting (aka “Language for non Unicode programs”) is set to Hungarian. But I don’t have any similar issues with Unicode in other software, so I’m suspecting there could be a bug, or I must be missing something.

Any suggestions? Many thanks.

Other than that, I’m enjoying vvvv very much. :)

Thanks,
Gergely

Which vvvv version(s) did you try?

45beta24… no text …

hmm my russian UNICODE is fine, not shown correctly only on input/output pins, in IOBoxes everything fine renders also no prob, i use eng w7 with location Russia… Try to check your languge settings deeper …

Thanks, but I have no idea what to check. I don’t think anything is wrong with my settings in general: vvvv is the only program having problems.

I could play with locale (language for non Unicode programs) a bit later, but that is time consuming as it requires a restart each time.

Try check on another Hungarian computer!
2-d sugestion that XP is better 4 v. I think that is in your system; vista still sux … and bill gates is a gay.

Ah, if BG is gay that explains everything, thanks. :)

May I dig this up? The Unicode problem is fully reproducible on any Windws system I have tried. (The problem is apparently not the sexual orientation of Bill Gates after all.)

If the system locale is set to Hungarian, I get garbage characters in Unicode.v4p. If I switch to English (US), it is suddenly all OK.

May I ask that you take a look at this, after I have identified the cause and provided the steps to reproduce? Or is everybody sleeping after a busy ad successful NODE? :)

I guess other languages could be similarly affected, Hungarian definitely is.

Gergely

OT: yah, for sure some of us had to catch up some sleep and also some work after NODE10 :)

just for curiosity: can you try beta23?

I’ve just tried an ancient version I have on this specific PC, vvvv_33beta14, and the bug is there in that as well.

“won’t fix” category? :)

helo gergelyv,

sorry for late. i can confirm this behaviour, without having any understanding about it.

i’d not say “won’t fix”, but i’d classify it “low priority” for now.