Forum

Camera animation stutters despite (seemingly) stable framerate

Hello, the attached patch is running at a stable 60 FPS on my machine (GTX1070i latest studio drivers).
Even though the camera animation stutters from time to time. No difference between windowed and fullscreen. Tried on primary and secondary monitor. Exported app behaves the same.
Tested with 2021.4.3. Any help appreciated.

CameraStutters.vl (179.9 KB)

I guess it could be micro stuttering. But before I go down that rabbit hole, potentially wasting a lot of time on a plethora of obscure bios-, windows-, driver-settings, I’d really like to know if I am doing something wrong or if maybe it is a bug in vl/stride.

Tried the patch on another system (i9-12900KF & RTX 3080Ti). Same problem.
Looking at the thing for longer time, I discovered that addtionally to the small stutters there are bigger ones that seem to be related to Gen2 garbage collections. I tried to prevent those by not re-creating bigger spreads but must still have missed something (see Deco process inside Room).

I’d really appreciate if one of the devvvvs could have a look at the patch.

Ok, forgot that the Present Interval for Scene-/RenderWindows is set to Immediate by default.
Setting it to One (and MainLoop Max FPS to 120) has somewhat mitigated the problem.

Still there are those GCs.

The GCs might have something to do with the instancing. Do you get the same problem if run the animation without them? Actually ran quite smooth for me do there was no visible lag. The performance meter moved around a little bit but there wasn’t anything consistent. like regular peaks and drops.


Allocations go up to about 3MB and happen pretty often, but Gen2 GC call haven’t moved past 88, in the short time I’ve been looking.

The patch runs very smoothly on my laptop when setting the fps with the Mainloop node. the laptop has a ryzen 5900hx CPU a gtx 3070 mobile GPU, 165Hz display and I set it to 55fps, which is exactly 1/3 of the display fps.

the GC2 collections weren’t present here. I think they might be artifacts from document loading, other patches, patching, or help browser. when you leave the patch running untouched, there are no GC2 collections, at least not in the approximately 15 minutes I tested it.