Building CEF with H.264 support


does anybody have tried to enable support for H.264 with HTMLTexture (EX9.Texture URL)?
I’ve successfully built CEF (branch 2840) with “set proprietary_codecs=1” and “ffmpeg_branding=Chrome” and can confirm that build is working via opening with freshly created cefclient.exe.
However, I can’t figure what should I replace in a %VVVV%\addonpack\lib\nodes\plugins. As soon as I’m replacing libcef.dll the HTMLTexture node turning red, when hovered over output pins. I’ve tried a different combinations of replacing cef.pak, d3dcompiler.dll, icudtl.dat but to no avail. Either H.264 is not supported via node or it turning red.
Do I need to build Xilium.CefGlue.dll somehow as well?

I’ve tried on Windows 10 machine with beta35.2. Both VVVV and CEF build are 32-bit.

Any help is greatly appreciated,

And you did indeed build the exact version as posted in the latest blog post? 3.2840.1513.gf7effc7?

That’s weird — I’ve just looked into cef_version.h and indeed, the version is wrong. It’s strange because I’m almost sure I remember that I’ve added --branch=2840 switch. Thank you.
Anyway, after rebuilding with the correct version — what should I replace besides libcef.dll?

Well I’d think the DLL alone should be enough. But to be sure copy all the files beside the cefclient.exe

Would be cool if you post the build also for people having troubles building it on their own…

1 Like

+1 for sharing

It’ll be probably best if I’ll wrap it as contribution (with included 64-bit build) in a couple of days.
As for now: here is an archive with working 32-bit build. It turned out that replacing libcef.dll is not enough — just drop the whole content of a .zip into %VVVV%\addonpack\lib\nodes\plugins.
I’ve tested it on a 35.2_x86

You can point your HTMLTexture node to to try it out, or use attached patch:
test-x264.v4p (4.2 KB)

1 Like

I remember from older CEF versions where H.264 support was still included that some ffmpeg dlls where in the build output - are those the files which were missing?

Yeah, I’ve read some old posts on Google Groups regarding missing libffmpegsumo.dll, but that’s not the case here. All of the files that should be copied/replaced in VVVV folder are already there. It’s just replacing only libcef won’t work and you need to replace others as well. Some of them are taken from \binary_distribution\resources folder and some of them are from \src\out folder of CEF build.
I’m almost sure that it’s not necessary to copy all of the 16 files from .zip but I’m to lazy to check one by one which files are required :)
Anyway, It works. So, thank you!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.