Forum

Build FreeFrame plugins with OpenCV

Hello,

I’m learning to write freeframe plugins with the help of the page : writing freeframe plugins
Until Step 7 all is OK.
But at the Step 8 = using OpenCV, the template (downloaded from the link in the chapter) doesn’t build. I have this message :
mingw32-g++.exe: \lib\cv.lib: No such file or directory
mingw32-g++.exe: \lib\cxcore.lib: No such file or directory
mingw32-g++.exe: \lib\highgui.lib: No such file or directory

I desperatly tried all settings concerning paths in CodeBlocks (linker settings, search directories,…, both in the project “Build option” and in the settings “Compiler and Debugger”).

I’m using Windows 7 64bits. CodeBlocks (with MinGW) and OpenCV 1.0 (if I understand, more recent releases are not usable in plugins in vvvv) are installed in C:\Program Files (x86), the 3 libraries are present, and I’m trying to build in a personnal directory in C:\vvvv

Would somebody know what I forgot to do, or have a clue ?

Thank you,

Matthieu

you did set the environment variable OpenCV as described, ja?

and in C:\Program Files (x86)\OpenCV\lib you should have the 3 files the linker is looking for, ja?

that should really be it.

btw. i’ve just updated all of the freeframes to opencv231. should be available in the vvvv sdk shortly. i strongly recommend starting to use the vvvv sdk already. and i’ll make a shout as soon as the opencv2 stuff is in there.

Ah yes, I didn’t set the environment variable OpenCV, now it works fine. I thought I had to do that OR set manually the paths in CodeBlocks, not both. I don’t know why I didn’t try it. Sorry !

And thank you very much !!

Good news that we will have OpenCV 2.3.1

Freeframe is dead
freeframe-dies-tonight

have a look at this.

so you can use cmake to set up your project. ReadMe is included.
and its VisualStudio/CodeBlocks …

freeframeextended-visualstudiocodeblocks