BUG: Windows Server 2012 - 45_beta34.2 create Renderer (EX9) fail

I’m running vvvv45_beta34.2 on a Windows Server 2012 with NVIDIA GRID GPU and when I try to create a Renderer (EX9) node I get an error in the TTY ‘didn’t create node; [0.v4p ////, without name (ID: 3)]: ‘’(nil)’’ is not a valid integer value’ and ‘couldn’t find/create node without name (ID: 3) in patch 0.v4p ////. deleting action.’

Here’s the exception vvvv.exe-exception-2018-05-08.log (27.8 KB)

All the DX11 pack nodes work and I have a complex project running with DX11 with no issues. I do really need DX9 working though so I can be share modules and patches with a very large, much older ongoing project that is all DX9.


odd…first thing i would recommend is make sure the nvidia driver is latest. then what you could do is run “dxdiag” and see if it complains about something. it also has an option “save all info to file” which you could do and share the file here…maybe it shows something…

Just tested on a Windows Server 2016 and same error.

Dxdiag reports no problems.

Here are both logs

DxDiag-Windows2012.log (19.9 KB)
DxDiag-Windows2016.log (47.0 KB)

If all the things they say about MS spying on you are true, well, just start talking near server about how much reliable Red Hat Linux is.

oh and GPU drivers are up to date

hm…so for the 2012 one, the log looks suspicious: what’s mentioned under “Display Devices” is not the nvidia card. and the mentioned card does not feature any “Feature Levels”. compare that to other such logs, where we see feature levels like “11_0,10_1,10_0,9_3,9_2,9_1”. so with this one i’d argue this would have to be sorted. not sure how/why dx11 can run on such a card though.

for the 2016 one, the log looks fine and i don’t really have any idea what would keep it from running. creating a dx9 renderer there gives you the same output in tty as on the 2012? also i have to say we’ve never used such grid gpus…

Yes I noticed the issue with the logs on the 2012 but device manager reports the GRID card and also vvvv DX11 works perfectly.

Yes same error on both servers (2012 and 2016) when creating the dx9 renderer (ID number changes if I’ve tried a few or created other nodes).

I can give you remote into the machine if you wanted to take a look. Also, lastest version of vvvv doesnt even launch on either the 2012 or 2016 servers; just shows the splash screen forever.

I’ve not tested versions between 34 and lastest. I could try this to give more info.

if b36 doesn’t launch at all, please run with /logstartup and post the resulting .log files here.
or is it just taking ages to load as mentioned in the first issue here?

b36 exception log and startuplog attached.

vvvv.exe-exception-2018-05-09.log (21.0 KB)
2018.05.09-17.03.58.log (1.6 KB)

does this help? Alpha does not start

might be that the vvvv.exe.config is missing somehow.
also your .NET framework installation might be broken or not up to date.

vvvv.exe.config is present.

Just updated to dot net 4.7 and b36 now launches on 2012 and 2016 server :). I can create a DX9 Renderer in b36 but doesnt display graphics nor change bg colour :(. No errors from TTY. Same results on the 2012 and 2016 Windows Server. DX11 renderers working on both.

dot net 4.7 hasnt helped my b34.2 dx9 plight either. still unable to create dx9 renderer and same error.


mkay…can you please send the exception-log you get now when trying to create a Renderer (EX9) with latest alpha?

there are no exception or errors in TTY joreg

can you please try running vvvv with commandline option /dx9? or try any release prior to b32 (which default to /dx9) just to see if it makes a difference.

that’s sorted it for b32 and 36 on all windoze server versions! thanks loads

good to hear. so it seems just to be a limitation of the hardware or driver that doesn’t support dx9ex.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.