Forum

Boygrouping difficulties

Hi vvvvolks,

Im trying to work with 2 pc using the boygroup; they are both recognized as server and client, the client has its IP in the taskbar but the server does not show its IP. I have created a Boygroup (Server) node in me server patch with the client IP and I can boygroup the nodes in this patch, but nothing happen in the client patch. What’s wrong?
I watched the Takethat patch from GirlPower and it’s at the same stage as my patch; I also had a look in the forum but didn’t find information.

And also, can anyone explain me broadly speaking the pins of both Boygroup nodes?

Thanx a lot

the server does not show its ip in the taskbar. that is correct. the client should show the servers ip! not its own. as you are starting the client with a command like:
/client serverip

and here some more info about the pins:

Boygroup (VVVV Server)
Inputs:

  • Clients: a spread of ip adresses of the client pcs
  • LogToTTY: lets you chose what kind of messages you want to see in the TTY-Renderer (useful for debugging only)
  • Broadcast Mode: chose which protocol (TCP or UDP) the server uses to communicate with the clients. for now use TCP. UDP will not work on some pcs.
    Output:
  • Connected: a spread corresponding to the ip-adresses on the Clients input telling you which of the clients are connected

Boygroup (VVVV Client)
Inputs:

  • ServerID: here you can set the id that appears on the output on the server.
  • LogToTTY: lets you chose what kind of messages you want to see in the TTY-Renderer (useful for debugging only)
  • Graph Request: OnEveryConnect: everytime a client connects it dumps its current graph and requests the whole graph from the server. use this during setup/debugging
    OnFirstConnectOnly: performance mode. if during the performance the client shortly disconnects due to whatever reason…it should not request the whole graph on reconnect since it will not have changed.
    Output:
  • ClientID: on the clients: their respective id. on the server: the id entered in the ServerID input

Indeed, I typed the wrong IP in my client Args! But I noticed those things:
*the Boygroup (Server) output shows a toggle slider instead of a numeric value. This toggle remains inactive whatever I do.
*I turned the server ID of the Boygroup (Client) node to 1 (always in the server patch), so the client ID turns automatically to 1; beside of that, whatever the server ID I type in the Boygroup (Client) of my client patch, the client ID is always -1.

I really don’t understand what’s happening, but thanks a lot for explaining the Boygroup nodes pins.

root-Boygroup (VVVV Server)#0.jpg (36.7 kB)

the Boygroup (Server) output shows a toggle slider instead of a numeric value
this is only so in the inspektor. its is just a different representation for 0 and 1. if you hover the output with the mouse or connect it to an IOBox (Value) you will see the value.

This toggle remains inactive whatever I do.
if the output does not show 1, then the client is not connected.

I turned the server ID of the Boygroup (Client) node to 1 (always in the server patch)
you mean by adjusting the ServerID pin right? this pin is there so that on the server you can simulate being any of the clients.

whatever the server ID I type in the Boygroup (Client) of my client patch, the client ID >>is always -1.
as long as the client is not connected to the server the Boygroup (Client) node will always output -1 indicating that it is not connected.

so i think you have to check your network connection. try the ping node.

That’s done! the problem was really stupid, in fact. I trusted the client IP given by vvvv , but this one is wrong§ I checked in my network parameters and the problem seems to be solved. The Boygroup (server) in the server patch is connected, the client id is 1 in the server patche and 0 in the client patch, et ça joue le chalet!!!

thanx a lot bwai, you saved my nerves!