Blackmagic UltraStudio mini Recorder - VideoIn (everyone ever used it?)

Did someone already try to get the Blackmagic UltraStudio mini Recorder running?

I just borrowed one from a colleague to test a proof-of-concept with images coming from a live video input, but was unlucky with all settings I tested so far, in the patch and on the driver side. Once I had an image for about one frame, while switching from 60 to 50hz in the settings (I don’t remember if it was the driver settings or some setting in the VideoIn node or the actual Input signal and also could not reconstruct it), but that’s it.
May it be worth installing all available older drivers from Blackmagic’s website, or may I be missing something here?
I read about magewell running fine because of the simple driver on the forum, and maybe I can get one to test as well, but I remember when using it for some live recordings, it constantly had drop frames and crashed the recording, though it was never used again and I wouldn’t see it as a realiable solution. Maybe it is though and something else was wrong with the computer recording…

You can install Videodesktop from BM website, and check with their media express software if you have an image.
What’s your video source ?
Blackmagic hardware accepts SDI level B Signal only. Your source might be SDI level A.


Sorry, I did not mention that. Of course the Signal shows up fine in MediaExpress!

Can you give a bit more Infos ( dx9 or 11 ) etc…
You can also try this :

I was testing dx9 and dx11 and all the videoIn nodes. Yesterday and today I was trying to recreate the whole scenario to give complete and right details.

In short: Suddenly the signal showed up just fine using the VideoIn node (dx9 and dx11). Also rebooting the system, attaching and removing the signal was no issue. also there was no problem like stopping, etc…
The only thing that changed is, that I am currently sending an SDI or HDMI signal (both working fine) from a Blackmagic VideoAssist Monitor/Recorder (but as I already said before, also last time the signal showed up fine in the Blackmagic MediaExpress Software).
The only strange thing is, that when setting it up the first time yesterday it worked on the v210a setting. Now it’s not but always working like a charm on the following settings (also note that since the last time testing, nothing changed systemwise like updates, software, drivers and so on):
Device: Blackmagic WDM Capture
Video Format: HDYC

The “VideoIn (DeckLink EX9.Texture)” node isn’t working at all, maybe it is just working with the “Decklink” range of Blackmagic products.

When switching the Device to “Decklink Video Capture” it keeps on working, but when switching the Video Format to “v210a” it stops, and will only work again when switching the Device back to “Blackmagic WDM Capture” and “HDYC”. It then also works again to switch to “Decklink Video Capture”. I assume, maybe there is some weird behaviour happing in the background?
I will keep on testing and attach it to a signal coming from a video mixer next time to see if I can replicate any issues or find out why it is working all of a sudden.

For anybody interested in the future, my system I am testing on is a MacBook Pro (Early 2011), Windows 10 Pro running via Bootcamp, Blackmagic UltraStudio MiniRecorder and getting a signal from a Blackmagic VideoAssist 4k via SDI and HDMI (Files are on SD-Card in the device, tested and working on 1920x1080 50i and 25p).


Seems like the nodes from the following contribution ( work (there is a dx9 and a dx11 version in there), both are fine so far. The dx9 version just misses the according YUV2RGB node to convert the colorspace accordingly. Trying to use the node from the %VVVV%\addonpack\lib\nodes\modules\TextureFX\Filter\YUV2toRGB\YUV2toRGB (EX9.TextureFilter).v4p just gives a white quad.

Also the %VVVV%\lib\nodes\plugins\VideoIn (DeckLink EX9.Texture) help.v4p just crashes.
It’s made by @elliotwoods. Funny thing is, also the EX9 version of the contribution seems to be made by @elliotwoods but as described works fine besides the missing YUV2RGB conversion. Maybe he can help with some clarification here?

Next thing to find out will be how to get a decent deinterlacing when dealing with interlaced input signals and why many nodes do not show up in vvvv when double-clicking and entering the name. they all have to be dropped in by drag-and-drop once when vvvv is open. then it will find them as long as it stays open. (all folders and links are set in the root patch)?

For a node to be found in NodeBrowser, its filename should follow this pattern:

Node (Category).v4p

There should be no problem, but before renaming the files, make a copy of the contribution, so you can revert it easily (what can wrong it’s that you could find some red nodes in other patches, since the filename no longer matches the one in the XML; you would then double click on the red node, and choose the correspondent in NodeBrowser).


did you try BlackSpout already? This is a separate application aquiring the video stream from the BMD devices and can be received via Spout in VVVV using this contribution. Check the live video window title for the Spout address.

Worked pretty decent for DeckLink capture cards for me.

Deinterlacing came up several times in the forum but only with “simple” solutions (e.g. here, no motion compensation and stuff).

Thanks h99 for clarifying that!

Thanks motzi, for the BlackSpout tip. At the moment everything is running super smooth, as described above. If I get more info or testing on that I will share the findings here. Will definitely have a look at the de-interlacing, and also see if I can check some decent deinterlacing solutions before capturing. (The only problem is, I don’t have a Capture-Card at hand all the time…)

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.