Billet Physics broken

Hi Guys :)
I was playing around with the Bullet Physics and i got some red nodes.
VVVV says it is all green the file in question is there BUT the node is red.

Any advices ?

See attached.

you do realize that bullet only works with 32bit builds? see missing in 64bit builds
which version+addonpack where you using? have you tried different versions?

Hello Joreg and thank you for the replay.

I am using b33.7 32bit.
TBH downloading older or newer version did not occur to me…

Will try that and will report later today.

beta33.3 32bit no go.
beta28.1 23bit no go.

When i try to add the RigidBody node on a clean patch TTY says :

00:00:53 * : Type ‘VVVV.Nodes.Bullet.BulletGetRigidBodyMesh’ not found in assembly ‘VVVV.Nodes.Bullet, Version=, Culture=neutral, PublicKeyToken=null’. Failed to create plugin node RigidBody (Bullet EX9.Geometry) (ID: 2).

When i drag the DLL to the patch TTY says:

00:02:22 ERR : Exception during extracting node infos from file C:\VVVV\vvvv_45beta33.7_x86\addonpack\lib\nodes\plugins\VVVV.Nodes.Bullet.dll: API restriction: The assembly ‘file:///C:\VVVV\vvvv_45beta33.7_x86\addonpack\lib\nodes\plugins\VVVV.Nodes.Bullet.dll’ has already loaded from a different location. It cannot be loaded from a new location within the same appdomain.
00:02:22 - : To help us track this error down, enable the ExceptionDialog via the menu or starting vvvv with /showexceptions.

Starting VVVV with /showexceptions :

00:01:44 * : Type ‘VVVV.Nodes.Bullet.BulletGetRigidBodyMesh’ not found in assembly ‘VVVV.Nodes.Bullet, Version=, Culture=neutral, PublicKeyToken=null’. Failed to create plugin node RigidBody (Bullet EX9.Geometry) (ID: 4).

i tried with latest 32bit alpha. opening:
(which is using this node) works for me.

Wired stuff.
I have 3 computers and on all of them is the same. Seems some external library is missing …
Need to investigate further.

Tanks for the help tho :)

forgot to mention: with b33.7 i get the error you describe. not sure what changed for a33.9 but there it just works.

i think bullet is 64 now only, and a member of dx11 pack

Kinda figured out what is happening.
After Antokhio mentioned there is BulletPhysics in DX11 i removed the VVVV.Nodes.Bullet.dll from the DX11 pack and all works OK now.

The VVVV.Nodes.Bullet.dll in the DX11 pack works on 32bit too ( at least i can drag it to vvvv and select a node). If i remove the Bullet DLL form addons and leave only the one in DX11 pack it all goes red and after a few seconds it goes blank with no pins. However if i doubleckick on the node and select its name again it actually comes on.However always double as if duplicated, 1 goes red the other shows up pins and can fix the patch but looses all connections.

Seems that 2 Dlls do not work well together.
Thanks for the hint guys, i will have some amusement for a while :)

Hi bro,

Spoke to Microdee about the exact same problem (he did the bullet physics workshop at node13), rigidbody node was also red for me… Runnning vvvv 64 bit by the way. YES the rigidbody node is RED and doesn’t work in 64bit, BUT actually you don’t need it… Here is the thing:

Fuck the RIGIDBODY node!

You don’t need it, actually, you can get all you need from using the getrigidbodydetails instead. Here is a screenshot of the BVH example from bullet phsyics showing how for me also the rigidbody node was red originally (left of screenshot) but then on right side of screenshot you can see how I fixed it., without using rigidbody node.

I attached another, simpler example, the 04 forces example in girlpower, again left side of the screenshot shows how I get red node and right hand side of screenshot shows how I fixed it.

Ditch that pesky rigid body node bro. Do it! peace


it seems to me the confusion comes from both addonpack and dx11 pack bullet nodes have exactly the same naming. i just fixed that by adding a version “DX9” to all addonpack nodes. while this is a breaking change if you have older patches that you want to target DX9 specifically, it can easily be fixed by doubleclicking/replacing the nodes.

btw. same was true for kinect nodes, where the same “fix” was applied for beta34.

Hi Joreg,

Thank you for the tip.
Just out of curiosity would this be fixed in future releases or we should do this manually as you explained?

And again out of curiosity, would my solution be “acceptable” / am I right to think the rigidbody node can be avoided? or am I missing some bullet functionality by ignoring this rigid body node?

Cheers man!

i made those renames for beta34. so when you have a patch with dx9-bullet nodes and open it with b34 it will be broken and you have to manually replace all nodes. if you open it with b34+dx11-pack all nodes will switch to dx11-nodes. this may not be what you want and you’ll have to replace them.

good thing with b34: now you can distinguish the two version. you couldn’t before.

your second question regarding the rigidbody node goes @vux

Thankx for clarifying Joreg, yes according to microdee the rigidbody node “can be ignored”. Cheers and good news about b34, looking forward to it! peace

I’m getting the same red-node problem in the girlpower patches and same message on the console with 34.2 x86 on Win7 x64. I can go to a clean patch, double-left-click, type in RigidBody and the DX9 version pops up top of the list, click it and get a red node with no pins. Missing a lib, or conflict with DX11 pack I have installed?

Checked the version of my installed addonpack, and the file says 34.1.0, so I thought ooops! must have mixed them up. But looking in addons_45beta34.2-01, that’s what the file says in both the x86 and x64 zips, same as in addons_45beta34.1_01. ???

as mentioned above regarding the red RigidBody node we’ll have to wait for an answer from @vux.

regarding the file: never mind the different versions. they’re not related and we only forgot to update the addonpack but that will not cause any harm.

Thanks joreg, I thought/hoped this bug being marked as fixed in 34_01 meant for the RigidBody node as well.