Forum

Beta40-0005 preview - cloning c# template results in error and node is not created

To reproduce:

  • open node browser
  • select Template (Value) c#
  • rename to e.g. “Test”
  • click clone

TTY:

00:00:26 ERR : System.IO.FileNotFoundException in ICSharpCode.SharpDevelop.Dom: Could not load file or assembly 'log4net, Version=1.2.10.0, Culture=neutral, PublicKeyToken=1b44e1d426115821' or one of its dependencies. The system cannot find the file specified.

Stacktrace:
   at ICSharpCode.SharpDevelop.Dom.LoggingService.Warn(Object message)
   at ICSharpCode.SharpDevelop.Dom.SystemTypes.CreateFromName(String name)
   at ICSharpCode.SharpDevelop.Dom.SystemTypes..ctor(IProjectContent pc)
   at ICSharpCode.SharpDevelop.Dom.DefaultProjectContent.get_SystemTypes()
   at ICSharpCode.SharpDevelop.Dom.DefaultClass.GetBaseTypeByClassType(IClass c)
   at ICSharpCode.SharpDevelop.Dom.DefaultClass.CalculateClassInheritanceTree()
   at ICSharpCode.SharpDevelop.Dom.DefaultClass.get_ClassInheritanceTree()
   at ICSharpCode.SharpDevelop.Dom.DefaultProjectContent.SearchType(SearchTypeRequest request)
   at ICSharpCode.SharpDevelop.Dom.SearchClassReturnType.get_BaseType()
   at ICSharpCode.SharpDevelop.Dom.ProxyReturnType.GetUnderlyingClass()
   at ICSharpCode.SharpDevelop.Dom.AttributeReturnType.get_BaseType()
   at ICSharpCode.SharpDevelop.Dom.ProxyReturnType.get_Name()
   at VVVV.Hosting.Factories.CSProjectFactory.ContainsNodeInfo(CSDocument document, INodeInfo nodeInfo)
   at VVVV.Hosting.Factories.CSProjectFactory.CloneNode(INodeInfo nodeInfo, String path, String name, String category, String version, String& newFilename)
   at VVVV.Hosting.Factories.AbstractFileFactory`1.Clone(INodeInfo nodeInfo, String path, String name, String category, String version, INodeInfo& newNodeInfo)
   at VVVV.Hosting.HDEHost.Clone(INodeInfo nodeInfo, String path, String name, String category, String version)

00:00:27  -  : Assembly of D:\Tmp\plugins\ValueTest\ValueTest.csproj is not up to date. Need to recompile ...

The file is created though. Dragging the project file onto the patch the node is created and works but it is still called “Template”.
Here is the plugin:
Valuetest.7z (4.6 KB)

Thanks, fixed for upcoming builds.