Beta30 rs232 node

I’ve just tried the new rs232 node, and it comes up red,
00:05:02 ERR : Exception occured in TMPluginWrapperNode.Evaluate: A device attached to the system is not functioning.

As soon as I enable it, the com port is correct, not sure about the other settings… Will adjusting them and see what happens…

quite a killer node right now. i just added the RS232 with no serialPort installed -> node is red and can’t be deleted anymore !

any updates? no idea about the device not functioning message …

i made a small change to the code so that the node will only try to configure the port if enabled. that the node is not deletable seems to be a tty renderer issue - the node throws an exception each frame -> renderer scrolls to end and in doing so grabs the window focus -> attempts to press delete fail as patch window doesn’t have focus anymore.

pls check latest alpha.

Also came across this behaviour, see: . I think it should be considered a bug and be fixed.

Funnily enough I opened a rs232 patch in beta30 yesterday, and it was fine, not sure if its the same pc as I made it on though!

cheers elias for the info

tty problem that was part of the problem in the first place (as mentioned by elias) now also fixed for betas>30.

@bjoern: the one you link to is already supposed to be fixed in >30 alpha builds

Sorry Guys,
I was being an idiot, the patch I opened in beta 30 was using a legacy rs232 node, as soon as I enable the plugin version, it goes red, and throws this exception and goes red, tried with latest beta too…

rs232 throws exception (45.9 kB)

@catweasel: could you try with latest alpha pls (rev f612838c)? the issue you’re experiencing seems to be driver related: it doesn’t support setting the break state - even setting it to false. i changed the code in a way that the break state will only be touched if set to true. the node will also catch much more exceptions now and will try to resume execution. make sure to also open the tty when testing.

Having a lovely time in Stockholm, until this error popped up:

00:04:30 ERR : Exception occured in TMPluginWrapperNode.Evaluate: The port ‘COM1’ does not exist.
00:04:30 - : To help us track this error down, enable the ExceptionDialog via the menu or starting vvvv with /showexceptions.
00:04:30 ERR : System.ArgumentNullException in VVVV.Nodes: Value cannot be null.
Parameter name: PortName

at VVVV.Nodes.Devices.Rs232Node.TrySetPortName(SerialPort port, String portName)
at VVVV.Nodes.Devices.Rs232Node.TryConfigurePort(SerialPort port, Int32 slice)

Any one got an ideas what’s going on? This PC has used all sorts of devices down the stretch but a part of me doesn’t believe this is some sort of external issue.


Sod it. I’m an idiot.

Cheers Beyon.