Backbuffer width & Height

Hello !

Just a little question concerning backbuffer; using renderer(EX9) I could easily set the backbuffer height and width with the input pins. In renderer(DX11) I can’t seem to find the trick. Viewport size doesn’t seem to be the answer either, or maybe I’m not using it correctly ?
Any suggestion on how to set the height & width of a dx11 renderer would be welcome !

As the help patch of the renderer states: If you want to render into a texture please use Renderer (DX11 MRT) or Renderer (DX11 TempTarget). F1 is your friend…

So the ‘normal’ Renderer is just to display the scene and it will always have the backbuffer size of the visible window.

1 Like

Thanks a lot Tonfilm, don’t know how I missed that one, I guess habits are hard to change sometimes;

old habits die hard… :)

Ive got a similar problem, a renderer that is full screen on a 1920x1080 desktop, that i’m sending to a capture card that is also registering a 1080 signal, yet the actual backbuffer width & height as reported by the renderer itself is only 1280x720.
How can the renderer be only 720 when it’s full screen on what windows says is a 1080 desktop? Is the renderer just mis-reporting it’s backbuffer?
Is there a way to force it to be 1920x1080?

any help/tips greatly appreciated thanks!


what does the renderers _Fullscreen Dimensions_-pin tell you?
you have to use an Inspector (VVVV) to access this so-called configuration pin

I’m having a similar problem as @fatalex - I have a 4k (3840x2160) monitor, which windows recognizes correctly as such, yet when I have the DX11 renderer go fullscreen, it reports it is only 1920x1080, and it looks it. The monitor reports itself as running at 3840x2160. So I’m pretty confident the display is really at 4K and the DX11 renderer is not sensing it properly.

just a random idea: is the windows desktop behind the renderer experiencing the same resolution weirdness?

Windoze “set resolution” shows it as 3840x2160 - this is on Win8 x64, 34.2_x86, latest DX11, and a GTX770 with latest drivers. I get the same on my Win7 laptop, with Intel HD4000.

More data:

When using a DX9 renderer, if it is set in Herr Inspektor for fullscreen “AsDesktop”, it only goes to 1920x1080 for fullscreen. But 3840x2160 is in the list, and when that is selected, it will correctly go to 4K fullscreen.

So apparently the DX9 renderer is also sensing the current res incorrectly.

Starting to sound like a vvvv bug in how it gets current monitor resolution.

This called DPI settings, look for advanced in resolution of your screen make sure there is 100% DPI


One other datapoint: With the DX9 renderer, when I set it to AsDesktop in Herr Inspektor, I get a message on the console “AsDesktop: 1920 x 1080” instead of the correct current res of 3840x2160.

Thnaks for the tip antokhio, but I won’t be near the 4K monitor for a few days. But I tried screwing with that setting on a regular HD monitor (150% was the highest option), and it has no effect on what AsDesktop means with the DX9 renderer or what res the DX11 renderer reports when it goes fullscreen - both still do 1920x1080. But I’ll check it out, thanks!

Surely I’m not the first person to try DX11 at 4K, so I must be missing something!

I had this few times, this also called change size of text, and other items.
I dunno why but i know on win 8.1 it affects rendersize, it also needs to have option 100% on every desktop

is the monitor connected via HDMI? we had such a 4k-Monitor once, having only HDMI (which is not supporting real 4K atm.) and it forced the graphics card to 30fps INTERLACED! So setting the Fullscreen-Framerate to 60 might result in 1080p, 60fps. I didn’t test vvvv with this monitor.
Does not have to do anything with vvvv, just in case someone has similar problems…

HDMI 1.4 does just support 4K 30p (and 8-bit color), but HDMI 2.0 supports 4K 60p and 10-bit color, and that’s what both windows and the monitor itself report it running at. So yes be sure to check what your monitor has. (DisplayPort also supports 4K 60p).

The monitor I’m having the problem with is in a University lab, so I just ordered one of these for my own testing; 24" 4K(UHD) 60p for $290 - cheap!


I have a 4k monitor and both dx9 and dx11 renderers are giving right backbuffer size ( 3840 x 2160 ).

The monitor is connected with displayport.
System is win10
GPU is GTX660 ( desktop machine, no laptop, no integrated GPU )

I might be wrong but I had the feeling that I have less High DPI related issues since I upgraded to Win10

@keftaparty what is the scaling set to on the 4K monitor?

@sunep : 150%

OK, big surprise, what I am seeing is a Windoze 8 problem. (I HATE THE 8!)

@antokhio, Win8 does apparently automatically set the scaling to 200%, which fools vvvv into assuming the wrong resolution. Changing the scaling to 100% (actually just listed as “Small” in the dialog) fixes it.

All works fine with Win7, I suspect I might have had a bad HDMI cable with my first Win7 test. I have not tested Win10, but @keftaparty sounds like they may have fixed it there.

What is odd though is that changing the scaling on Win7 does not cause vvvv to use the wrong fullscreen res - but in Win7 I can only set scaling up to 150%, not the 200% Win8 uses by default with 4K.