Forum

Audioproblem with bass...can't hear a thing

Hi,
got this little patch here which is supposed to play samples by pressing on the numpad. Well, if I do press a button I can see in the inspector of the filestream that “play” is set to 1, but no movement in the “current position” number. Saw it moving once, but stil no sound to hear at all…

I just can’t figure out the reason for it, tried already all kinds of different settings but no result. can anybody help??

audiosampler asio try100.v4p (12.2 kB)

Well, your filestream nodes only play between starttime 0.00s and endtime 0.00s, thus playing for 0 sec (and 0 sec of sound is sillence ;) ) fix that by making the endtime something like a 1000 or something.

The togedge is clever, but I would use the Up Edge pin, to maker it seek on start, dunno way actually that would make any difference, just feels better, to initialize stuf at start, rather than at the end.

The Keyboard node seems not to output a spread on the Keycode pin when I press 2 keys, THINK IT IS A BUG, so not much use for the mixer here, but let’s fix that…

Ok I think I got it now for the most part. But occasionally I still get the same problem even with the endingtime set (current position stays zero). And if it depends on setting the ending time, why does it still play then sometimes even if its set to zero?