AudioEngine with Realtek ASIO

I “just” want to get sound from my built in mic into vvvv.
I tried using with asio4all (2.14 and 2.15b2) but unfortunatly my built in microphone array doesn’t even show up in asio4alls settings panel. I’m using a MS Surface Pro 7 on Win11, btw.
So I looked for another solution and found out, that Realtek is providing native ASIO drivers. I installed those and they actually do show up in the audioEngine node. But they are not usable, the node even turns pink from time to time.
Is there any way to get this working?
As already pointed out asio4all seems to be not usable, so I’m a bit stuck on this. (The FruityLoops driver didn’t work, too.) Maybe it’s just a security problem or sth like that, but I can’t figure it out…

What does the tooltip say in that case?

Hard to say, because it keeps that state only for a second or so. Usually it just does not provide any output.


Enable runtime pause on errors in the settings.

Yay, the error WAS “Samplerate not supported”, so I tried all of them. And 48k actually works! And now I also get an output from my mic via AudioIn, great! Windows even shows that vvvv is using the mic in the settings. Thanks for the pointer!

If anyone is interested: I used this instructions to get the driver from here.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.