Forum

Assimp nodes DX9 broken in 64bit

Hey everyone,
i was digging in the old mre.mdmod trying to create a scene but i noticed the Assimp nodes are red.
I am using vvvv 45beta34.2 x64. I tried dragging the dll directly in the patch window but the nodes are still red.
Works fine on vvvv 45beta34.2 x86 tho.

Can anyone please test if he got them working so I can isolate the problem to my machines?

Tested on 3 computers including clean installations and still no go. The exception dialog is showing a lot of information but sadly i cant figure out whats wrong and how to fix it by myself.

Any help/ advice is appreciated!

vvvv.exe-exception-2016-04-24.log (27.9 kB)

Nobody uses 64bit vvvv?

Check if you have all the dependency installed in the bottom of the page https://vvvv.org/downloads

Everything is green in the check boxes. That is why I am puzzled as to what is happening.

well i can confirm that DX9 assimp node is red here also with same error…
don’t think there is fast cure for that…

Thanks for the confirmation @antokhio :) dx9 will have to be dealt with 32bit vvvv then.

I unmarked this as solved since it is still a problem - at least for me, I get all red DX9 assimp nodes in 34.2_x64. Anyone have the DX9 assimp nodes working in x64?

More info: depends.exe dependency walker shows the VVVV.Assimp.Nodes.dll in the x64 addonpack as an x86 library, which causes havoc with incompatible libs and missing delay-load dependency modules.

@vux is there anything we/you can do about that?

1 Like

Well things don’t look good, 50beta35_x64 addonpack still has the DX9 help files but now no assimp libs… need to get to the vertices of a model, but in DX11 the InstanceNoodles03 GetVertexData appears broken (doesn’t work even with Teapot).

there is info assimp node, then you can look on pointeditorCS, and if you need just vertex count you can use copyCounter.zip (4.7 KB)