Assets are not loaded in stride (filetexture, filemodel)

Hi everyone, sometimes i see this problem on different pc’s, and sometimes it can be fixed (not sure how) but not always.
In the hep patch “HowTo load assets form file” nor the texture neither the model are loaded, there’s only null on output.

last time i had this on a desktop with win 8, it was fixed with new installation of gamma with “install microsoft build tools” checked,
but now two of my students have the same problem (one on win 11, another on win 10), and installing ms tools does not help.
we even tried to install stride standalone (who knows), but still not working.
other stride patches are fine, and fuse also.

i see this problem rather regularly and wondering that i can’t find any related discussion on the forum, maybe it’s just so simple that no one needs help…

also, in the example “day and night” textures are loaded, i found inside the materials that it’s done with gameasset node

It’s likely a vc_redist issue, the loaders tend to use some specific version, i think for assimp you need 2013 one. I guess you need to check witch ones are installed, and install the rest, this would be the most obvious case for this problem…

Thanks, we’ll try,
and what does it mean “the rest”?
is there a list of them somewhere, or i need one for each year since some point?

Usually u need ones from 2010 and up, some libs like assimp has the ones like 2013 in dependencies

You also need MsBuild, it is needed for the asset loading system at runtime. So if you install vvvv, enable this checkbox.

The vvvv installer also takes care of the VC++ redist installation.

yes, tried installing, uninstalling and reinstalling several times, with MS build checked, didn’t help. will try to check and install vc_redist manually

i guess, if the installer sees that some VC version is installed, but it may be a little bit different, installed previously by another software?

seems like had some issues with beta before, and manually deleting VC and installing again from beta “installer” link helped then

deleting vcredist 2013 and then reinstalling vvvv fixed the problem, thank you


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.