ArtNet loopback / UDP exclusivity

Hi there,
I think this is a feature request, but who knows maybe there is a solution out there already.

Problem is: in a localhost-enviroment I can loop back DMX data (ArtNet) inbetween various softwares, but not from/to VVVV. I.e. I send pixelmapped ArtNet from Resolume to QLC+ on adress, works like a charme. Other direction as well. But I cannot send to VVVV or receive from it. (For context: I use ArtNet from VVVV all the time, but via network adapter; it is working for me in general).

Possible issue could be UDP port exclusivity. This is from one of the Resolume programmers:
“Officially, it’s not good practice to allow two programs to both open the same port. This makes sense, because otherwise, you can’t be sure which app is sending the data, or which app is actually receiving it.
There is a way that you can open a port ‘non-exclusively’. This allows for such wonderful things as two apps sending and receiving Art-Net on the same computer. We implemented this for Resolume on the 5.1 release.”

Ay chance to get that in the future?


hei mfo,

please try this with the new ArtNet (Network Sender/Receiver) nodes in latest alphas, and report your findings!

1 Like

Hi Joreg,
looks pretty cool! Local hosted loop-back is working fine for me, will test in a full setup asap (ArtNet looped back + output on network adapter).

So, unfortunately the full circle doesn’t work.
I’ve tried: Resolume’s ArtNet Output via Localhost into VVVV, then take that data and send it via a separate network controller (address in the 2.16.16.* range) out into the physical world (a DMX-Artnet-Node).

The two separate steps are working! But only separately. Both in one patch fails.
If I start Resolume first, VVVV after, it displays a “Could not bind socket. Address and port are already in use” error message. Log is here: vvvv.exe-exception-2017-12-16.log (30.3 KB)
If I start VVVV first and Resolume after, then Resolume gives me an almost identical error message. “Another program is already using the port”.

Now here is the strange part: As mentioned above, If I only use the localhosted ArtNet-from-Resolume-to-VVVV functionality then it all works fine. None of the two has any problem with used ports.

@mfo : I’ve been using such a setup with no problem.
It was:

  • Artnet generated in ETC Cobalt, sent localhost via loopback to vvvv .
  • some filters in vvvv
  • Artnet sent from vvvv to an Artnet/DMX Interface.
    Only difference I can see is that my external Artnet node was configured with a fix ip. The loopback was also configured with fix ip for what I remember.

Hi Keftaparty,

my ArtNet node uses a fixed IP as well.

In any case, after your post I tried again - and its all working now! Pure magic. Didn’t even change the patch or anything.
Maybe installing the latest Alphas required a system restart? It shouldn’t, no?

So, yeah, good work, thanks Joreg!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.