Forum

ARTK IDs problem

hi there

I was trying the ARTK plugin, but can’t solve some of the big problems that other people have:

The Ids problem, and the Flickering. Now i’m most worried about the IDs

do you use a webcam? most of the errors come from noise in the image and slow framerates…

webcam, yes. i’ll try with a DV to see what happens, thanks

it’s long ago that i tinkered with the ARTK and right now i don’t have that markers around.

but i remember quite well that there always have been some problems with spikes and dropouts of received data.


i would try it this way:

1

i would try to find optimal settings for all DirectShow related parameters as there are e.g.:
*Reference Clock (Configuration Pin!) setting of VideoIn (DShow9)
*Framerate setting of VideoIn (DShow9) regarding to your hardware
*Wait for Frame settings for VideoTexture (EX9.Texture VMR9)
**maybe instead of the
++VideoTexture (EX9.Texture VMR9)
++the
++VideoTexture (EX9.Texture VMR9 YUVMixingMode)
++even works better ?!?
*set vvvv’s framerate by using MainLoop (VVVV) with Time Mode= Filtered according to your cam parameters
*Presentation Interval (Configuration Pin!) of Renderer (EX9)

maybe there is even more to take care about.
because neither DirectShow nor Videorendering in general are my core competencies i cannot provide solid knowledge about this.
but basically is this the way to go. furthermore i assume this will also have a very positive effect on spikes and dropouts.

2

regarding the dropouts you may find an approach in the GetID-module within the FiducialTracker (Tutorial).

anyway a clever combination of S+H (Animation) and Select (Value) should solve this problem.

3

once upon a time i created a module:
Transient (Animation Filter).v4p
for exactly the purpose of ignoring spikes.

this module can be downloaded at kalle.Modules.Animation

but while having a look at it i have to admit that this is an quite “old” module of mine…
i am sure that i can do this module meanwhile lots better now and i will try to improve it’s functionality soon.

That really helps kalle

I have solved the IDs problem, but now it appears that the flickering has gone mad with the cam, and don’t even give a correct position. I don’t know if it has something to do with the Get matrix

attached also an image with a marker to try it without a webcam. also the same problem…

That really helps kalle

I have solved the IDs problem, but now it appears that the flickering has gone mad with the cam, and don’t even give a correct position. I don’t know if it has something to do with the Get matrix

attached also an image with a marker to try it without a webcam. also the same problem…

ARTK.rar (164.9 kB)

Weird… I replaced the folder with the one on the older thread and now works perfect