Forum

Artifacts in EX9-renderer

I got some really weird artifacts in the renderer, see pic.
I rebuild the patch a second time - exactly as the first one - and the artifacts don’t show up.

I had this some days ago allready, but it disappeard suddenly so I didn’t think about. But know it won’t go away.
Tried reloading .x-files and recreated the GouraudDirectional-nodes. Didn’t help.

Does someone know about this?

EDIT: Tried all settings for backbuffer and so on, too, without success.

artifacts.jpg (16.1 kB)

its not like u haven’t set the depth buffer? if u have plz post the patch…

No, depth buffer is set (for windowed mode where I took the screenshot).

I added only four of the .x-files. Else it seems to be too big.
Don’t know if neccessary, but I added a node called “alphacam”, too. Has to be put into a folder named “alphazen” in the modules-folder.

PC_logic is the one that works. PC_logic2 is the weird one.

artifacts2.zip (207.0 kB)

still looks like a depthbuffer problem to me that can happen with certain settings of cameras FOV and near/far-plane.

if it is a problem you can therefore increase the nearplane, reduce the farplane or see if your graphiccard allows for a higher resolution depthbuffer (there is usually D16, D24 sometimes even D32 available, see inspektor with Renderer (EX9) selected).

O_o"

You solved it, it was a matter of Near Plane. Thank you!