Arduino UNO & firmata


I try to connect the arduino uno to vvvv by using the firmata node.
i use windows7, vvvv25beta14.1

I tried uploading the Firmata-2.0beta3 (firmata standard) by using the arduino-0016 but the program didn´t work (just changed the colorsheme in windows7).
So i tried to upload it with arduino-0022. This worked but i don´t get any output on the board, even i see the operating led on the arduino uno is blinking when i use the arduinoUno patch that was demomstrated on the NODE2010.
The hardware seems to work cause if i try the same pins with the standardfirmata that come with the arduino-0022 and use the firmata_test.exe i can control all devices i connect to the board.

I get confused by all the different versions and different ways of how to make it work.
Does someone have an actual way of how to make it work ? What arduino IDE i have to use and what is the right version i have to upload to the arduino UNO? what version of vvvv i have to use ?

Thank you for your help

jo stephan

for me it worked just to use IDE 022 and the newest vvvv, so that should not give any problem…
just use IDE 022 and replace the firmata… then upload standard firmata

sometimes you have to do some on/off switching in the vvvv patch before it works
but i did not use an arduino uno so dont know if that changes anything

take a look 3 threads down, I had the same problems…

if anyone has a clue how to get it working with an arduino MEGA, i’d like to hear it!


Hello artvt,

what kind of firmata did you use to upload to the board ? the version that comes with aduino-0022 or did you replace teh firmata folder in the libraries?
If i use the firmata2.0beta3 version i get an error when compiling it or uploading it to te arduino by using arduino-0022.
If i use the “FirmataStandard” i found in the web posted by massimo/arduino i get an error as well. i found it here:
Any other idea ?

firmata2.0beta3 is the only version which works with the plugin ! it doesnt make sense trying different versions of firmata.

it does makes sense to try different arduino IDE’s because some don’t like to upload the old code.

uno is new, not tested, has a new driver if i’m not mistaken. this could be the reason for trouble.

ok, after havin problems using the “2.0beta3” with an older IDE i used the “firmatastandard” from the arduino guys that was used on the NODE2010
I was able to upload with the arduino-0020.
When i start the arduino help patch i see that the board gets data (incoming data led when pvw data is send) but the connected led is not blinking, even i tried different outputs. The same output worked with the firmata-test.exe before when the “firmata_standard-22” was uploaded on the board. so i´m relative sure of the pins on the sensor shield. i tried the outputs 00-05 that refer to the pins 11,10,9,6,5,3. none of that outputs gives me a blinking led. Someone knows about this ?

is it possible to change the driver of the uno ?
In the workshop on the NODE2010 everything worked fine with the UNO and now i just try to redo everything.

as well none of the analog inputs flicker…

hai stephan

well it sounds a bit weird but I have 2 computers running with the IDE, I first tried one, didnt work, but the other does, so maybe that can help

or different IDE’s as u7angel says

I am not shure but if I remember well, I used the same as you do (the one in the link)


you can’t just change the driver…

from the arduino website : It is similar to the Duemilanove, but has a different USB-to-serial chip the ATMega8U2, and newly designed labeling to make inputs and outputs easier to identify.

it is really simple, if you managed to get 2.0beta3 onto the board and the plugin doesnt do anything, it most definetely will never work. it doesnt matter if you change driver, mess with different firmata versions…whatever.

the reason is the plugin works with a baudrate which only 2.0beta3 uses.

whatabout basicmata-arduino-interface

What IDE did you use ? I thought when there is no error message after uploading to the board everything is ok. If it´s like this the code is already uploaded. Or do you think it makes sense to try other IDE versions as well ?
I just wonder cause i see the UNO recieving data in the same rythm as the pwm data is sent by vvvv. if i turn of the checkbox of the pwm the led for recieving data stops working. but on the other hand i don´t see any flickering input recieved by the firmata.
The same effect i had when the arduino 22 / FirmataStandard was uploaded.

thats what i was trying to say…it sounds like you successfully uploaded the firmata software. but the plugin doesnt work. therefore you can come to he conclusion…it won’t work.

seems like something changed with the uno version. some LED blinking is good, tells you at least some serial communication seems to work but plugin and uno don’t understand each other for some reason.

Thank you for the link to basicmata. I haven´t seen that. So i will try this as well. Thank you for your help.

try to get your hands on an old duemilanove, probably works fine

Hi Stephan
(I am from Argentina, and a dont know very well spech english…)

I have the “same” problem!

Arduino UNO + vvvv_45beta25.1 = problems…

I used Ide 0022

I used Mega and Duemilanove and no problems, but when i used UNO, It does not work Firmata…

Did you solve it?

fabian urban

the current firmata plugin will only work with Duemilanove and older.

Uno will not work.

Mega is not fully supported.

Hi u7 its very strange. Are you talking to port com or to ftdii chipset?

With whitecat i was very happy to see that all my serial talking to comport wasnt dependant of unos/ftdii drivers.
Maybe futur implementation should only discuSs with com port?

About code its usually a problem of evolution of core libraries. Or libraries that were external and where agregate and modified in the core of libs

just saying the arduino uno is incompatible with the plugin. no need to test stuff to get it working until me or someone else makes a better version of the plugin

i put the thread to resolved so ppl stop trying pointless things with the plugin.

hi u7 thanks for your reply. it was just a statement: ths plugin should work in another way than device related

you are right, since there are so many different arduino boards out there and firmata changes constantly, there is no way to make a carefree plugin which hides the ftdi/serial part from the user.

on the other hand, if someone just needs an usb io board, there are far easier solutions than arduino plus firmata. i think lots of people buy an arduino, try the blinking led example and then try to turn it into an io board with firmata. some of them give up along the way of firmata arduino serial communication problems with whatever software, let it be flash, processing or vvvv.

teacher should tell people, if you just want to attach a poti or sensors or servo to your computer driven projects, get some ready to go io board like phidgets.

it is actually possible to communicate with Arduino Firmata via RS232 node.
an example how to do it, based on the very first Firmata protocol can be found here

i couldnt get hold of the uno yet, but reading forums i bet its just some baudrate problem. one needs to adjust the baudrate in the firmataPlugin Code and the firmata software on the board. anyway, no proof yet. i will have time and an uno in a bit.