Arduino problem

hi there

I am facing some known problems here
my arduino board (black chip says ATMEGA8-16PU) wont upload any, I am just trying to upload the blinkin-led sketch as a tryal but it does not work.

I think it has to do with the fact that I can only see comports in the tools-serialport menu instead of the usb drivers. I have reinstalled the usbdrivers a few times but it still wont work

this problem is known because I can remember having it a few years back also, but I cant figure out what I did back then.

can anybody give me some advice?

thanx a bunch


can anybody give me some advice?

Does the arduino show up in your hardware? (USB Serial Port, in Ports)

You tried to stick it in a different USB port?

Be sure only 1 app is using the Arduino at the time (so NO vvvv when writing/uploading your code)

You read the Arduino Troubleshooting guide?

Also before uploading, make sure you press that little reset button (I forgot that once and spend a nice evening on the internet figuring this out).

hi west

thnx for quick reply

i’ve done all that, I have nothing running exept the arduino environement, but I do get an error that “serialport is allready in use, try quitting any program that may be using it” but as I said I am not running anything.

while installing drivers I saw that my comp installed the arduino as serial port and not as serial to usb convertor.
do you have any clue how to change that, where find the right drivers

arduino shows in hardware, as USB serial port
tried different ports
read all the troubleshooting things


it works

thanx west

The driver is a ‘virtual comport’, so you can communicate it with classic serial protocols, like the vvvv RS232 node or the Arduino software, no need to change that.

Yes, thanks for reminding me you could indeed change the COM port it gets assigned to.

But all in all, happy it works now :)