Arduino Firmata analog ports report problem

i have some trouble getting analog data from Arduino UNO to VVVV.
Im using an Arduino UNO with StandartFirmata V2.1 (same problem with V2.0) und the Arduino Firmata Plugin from the AddonPack. If i Enable the Arduino in VVVV and the “ReportAnalog” Pin i shortly get same values from the Analog Pins, maybe for one frame or something, then it stops reporting.
Reset, Disable and Enable the Arduino as well as restart and reconnect does not help.
I tested also different Arduino UNOs and different PCs…
is this a known problem?

Hi Lrinke,

I’ve never had this problem before.
Is the TX LED on the Arduino board constantly blinking during your analog tests?


hey robotanton,
the TX LED is flashing, when i get some values, but it stops flashing with the values in VVVV.
When it stops reporting, the RX LED flashes up shortly.
The connection to the board is still active anyway, im able to control an led on pin 13.

Hi Lrinke,

Hm. No, it’s not a known problem :/ Did you test with the help patch? Did you test with a different board?

We had a lot of boards running with the plugin.

It might have to do with the driver and related to that the buffer size, which Windows might not cope with. The buffer on the Arduino is very small (64 bytes), so don’t bump anything to imaginary values ;) try installing the latest Arduino IDE - with it comes the new driver.

Is it an original Arduino Board or a clone - a cheap Chinese one maybe?

Ping :)

Has this resolved yet?

Hi jens.a.e,
i tested it now with the current Arduino IDE 1.6.9 and newest VVVV.
i have 3 Boards here to test, 2x Arduino Uno and 1x Duemillanove all are original from Arduino (no china fake)
I just used the Helppatch as it is in VVVV
Same result with every Board, if i enable “Report Analog Data” the data starts to flow but stops after 1-4 Seconds.
I use a MacBook Pro with windows 8.1 installed as BootCamp (no virtual Machine or something) but i have the same result on an iMac with windows 7 with completely different Arduino Uno Boards.

Hey again, i found an arduino Lilypad USB in my shelf, with that the issue seems not to appear.
So it is only with Arduino Uno and Duemillanove.
I could test it now also on my windows 10 machine with the same results

Thx a lot for the extensive testing!!

Hm. That seems strange. It rather smells like a buffer overrun und the hardware side of things. I must check with the latest Firmata firmware update; you could try an older Firmata version; irc it should be something arround Arduino IDE 1.2-ish - at least Frimata version >= 2.3.

You can download the Firmata separately here: Just download the Arduino-* zip and use as a regular library. It should pop up in the IDE under the local libraries.

ps. make sure to download a 2.3x release…

Hi…as per my observation your problems are more likely in how the hardware is connected to the Arduino, or in how the PC application is trying to use Firmata on the Arduino, than they are in the Firmata sketch itself.When you change things in a sketch like this, you should clearly identify what you have changed, and why. If the what and why are reasonable and necessary, the standard sketch can be modified, so everyone benefits.

blind vias pcb