Forum

Arduino communication using multi-instances VVVV patch


#1

Hi Everybody,

we are working with multiple instances patch in VVVV and one of these instances is communicating via Arduino with the RS232 node.

We are experiencing some strange behaviour here:

  • When the RS232 instance of V4 is in foreground everything works fine: Arduino loop is working well, data from it are correctly received by V4 and correctly dispatched to other V4 instances.
  • But, when RS232 instance is in background the connection with Arduino is lost (last output from RS232 node is zero!). As a consequence Arduino loop starts behaving erratically and ather V4 instances are not receiving data anymore.

Trying to solve the issue we tried the following:

  • Bring the RS232 instance to top using the “ShowWindow” node and forwarding data from Arduino the other instances using the “UDP” node --> This doesn’t work! Connection stays open (even if with a little flicker) but data are not forwarded!
  • Bring the RS232 instance to top using the “ShowWindow” node and forwarding data from Arduino the other instances using the “Shared Memory” node --> This works for us: connection stays open and data are correctly forwarded.

Any ideas, suggestions?
Thank you very much for your support


#2

hey moscardo,

just a suggestion : have you tried using the new Firmata nodes rather than the oldie RS232 ?


#3

Hey, I think Firmata is not the answer when you write your own protocol of communication (ej driving leds).
I have the same setup and all I had to do is to set the mainloop both fore and back at the same fps, then bind the send and set vvvv to increment.
serial.v4p (11.1 KB)


#4

Thanks for the tip :)


#5

Hi guys and thanks for your help,

unfortunately I can’t use the “firmata” solution because I need to upload my custom firmware on the Arduino.
Unfortunately also the “mainloop + increment” solution doesn’t work for us :(

Here I’m attaching a video in order to show you what kind of problem we are struggling with.

2018-07-20 14-26-01.zip (695.1 KB)

When we move from instance 1 to instance 2, the serial communication stops working!


#6

Isn t that normal if you are using the IsActive node?


#7

Thank you very much @io.
You are right: problem solved!

Don’t know how but we forgot the “isActive” node inside the patch and were no more able to see it :P

Thanks you so much.
Thanks to everybody for your support