Alpha blending on MrWiggle

I am applying a squared texture with alpha channel over a grid, but I am not able to have the transparent part of the texture to blend properly with the other elements on the renderer.
(Of course I could try to create a proper mesh for the image I am using…)
I tried different settings with the Blend (Render State) node but with no results… is it even possible to achieve?

a patch demonstrating the problem may be helpful

ok here it goes a simplified patch.

patch.rar (177.2 kB)

hello, i assume that you have the depthbuffer enabled. the depthbuffer does not look for alpha pixels. you can try the node AlphaTest, but it will only work pixelwise.

to get a better understandeing you should read this page: Transparency. you will see, that this is a nontrivial problem for you graphics card.

ok, time to improve my Blnder skills … or … if I am not mistaken there is some “easy mesh sketching patch” somewhere …

this works here

akvarium.v4p (17.9 kB)

Thanks Kalle AlphaTest greater than made trick, meanwhile I ve learned some Blender key combos…