Forum

Alpha blend with nasty fringe

Hello dear vvvver, I’m testing a DX11 particle effect and used a transparent png with sprites. There’s a question.

When I use Blend mode advanced with AlphaToCoverage checked on the result sharpened and less look like my original texture. Uncheck the ATC the color is satisfying but only left thick black fringe.
After I searched it seems to do with premultiplied alpha. I don’t know if its right, can anyone help me?

ParticleAlphaTest.zip (450.9 KB)

You don’t have much option with particles, should be blend Add or AlphaToCoverage or blend without depth buffer enabled…