Forum

Address (sampler state)

Hi,
I’m working on a kaleidascop-like patch and I need to use the Address node to mirror a texture. My problem is Address doesn’t mirror anything and just clamps my texture. Impossible to understand where the problem come from.

Thanx vvvvolks
Alex

some older graphic cards do not support the more advanced modes like mirror or border. i hadnt any problems with newer cards for ages.
does the Renderer (TTY) show something?
alternatively you could use Cross (2d) to make your own patterns. An even more flexible way would be creating an X file with a grid whose texture coordinates are arranged after some caleidoscopic system.

Thanx oschatz,
Actually, my patch is the adaptation in v9.1of an older one made using v8.1 and, by this time, I had no problem. I think it’s a bug from Address in v9.1
. I checked the renderer TTY and it shows nothing.
I’d try creating but don’t know how to… so I think I’ll mess around with a cross 2D.

I will report my experiments.
Alex

I second the x file method, I spent ages trying to write a pixel shader to do polar coordinates, and couldn’t, then had the brain wave to take a plane and bend it into a disk, and export to x file, took me 10 minutes!
Sometimes thinking laterally really helps!

Ok, so…
I tried none of your solutions, I just re-made the patch from a blank window and now it works better. Pretty strange, ain’t it?
Anyway thank you gus for your advice.

Alex

Hi!
Back again with this f****** address node… Actually, the node works well with a Filetexture or a VideoTexture, but I can’t get mirror mode when I plug a Dx9Texture…
Really don’t understand…

ahlo jim.

i think i remember there are some restrictions for some address modes regarding texture type and size. try a dx9texture whose width and height are both power of 2 (eg. 512x512).

Wunderbar! Fantastisch!
It works!!! didn’t know this tip about texture size with address… but it works great, thanx joreg!

Alecz