Forum

AccessViolation

getting weird exceptions here, with the RC beta40#0023:
image

Try to reproduce please:

  1. open new patch
  2. insert Template (Value) [vl]
  3. open vl patch
  4. delete all content there (i.e. the input and output pin)

Hm, works just fine for me. Earlier beta40 versions don’t show this behaviour?

@velcrome any chance to get more info on this? can you clearly reproduce this?
we tried here on two different machines and can not.

we’d like to handle this asap as it is currently blocking beta40 release.

I tried again, this time it didn’t fault.
So sorry, no clear reproduction even at my end. Something else must have broken it, and what I observed was probably just a (at that time reproducible) symptom of something terribly awry.

I tinkered with the AzureKinect lib and its Observables, if you are looking for clues.

If stuff like this happens again, what would you advise we do?

ok, thanks for confirming.

I’m afraid i don’t have any meaningful advice for such situations other than when trying to reproduce such an error, start from scratch. ie start a clean vvvv, and not from a state where the error just has happenend.