A sub patch opening itself opening in itself opening in itself

Hi !
is there away to avoid the following bug ?

I m using a same subpatch many times in a patch.
when opening in my patch the subpatch, this one opens itself automaticaly.

using Ctrl D and being to much quick, Ctrl D will duplicate my subpatch at one moment ( one subpatch is opening and Ctrl D is pressed at same moment ) in itself, putting vvvv in an endless loop…

obliged to shutdown win to escape it !


huh, can you say that again?
i cannot follow. the only thing i would point out is that it should definitely not be possible to create an instance of a patch in itself. this is prohibited by design. if you found a way to really do exactly this, please offer a little example and again explain stepbystep how to reproduce it.

hi joreg. definitively this is a good old bug…

first I m using patches and subpatches without relatives path .
everything is set under C:/

I m using multiple times in different subpatchs a subpatch that i will call X to be clear.

when patching , i m inserting X by “open in patch” .
doing this will open automatically a window with X patch. This window is pushed in front, over the main patch window.

when making a too quickly Ctrl+D 3 or 4 times ( when you wnat to duplicate your X patch), it can happens that duplication is done while the window of X is pushed in front.

this is creating the bug of an endless opening.

yes i know, it was not possible, but I arrive to do it …


because that window accidentally (or by bug) gets onTOP?

hi kalle, hum… you mean I should Ctrl T to set my patch always on top, as an habit, thats right ?

is there anything to avoid a subpatch to be open when doing > open in patch > ?
personnaly i would really prefer …

nb: jigg was nice, i learned a lot on network issues on my jigg saturday. still asking myselve on this complete interpolation of data coming from artnet to vvvv values… not sure that a solution may fondable…



i only think that the behaviour you described is related to thia bug and your CTRL-D finger is perhaps a bit nervous…

my ctrl-D finger becames parkinson, but no near the T…
i m sure of it, from my old age…

any idea on HOW to block the pop up in a window of a subpatch when called ?

nb: did you notice that they are all over 40 with muscles etc ???

any idea on HOW to block the pop up in a window of a subpatch when called ?

yeah, ask the devvvvs to work on the “stayontop”-bug


am i right that the problem only exists when CTRL-D-ing a subpatch which is not hidden?

well, its how i arrive to do it on my little and slow machine…
yes ;-)

still can’t think of a way how to create a patch within itself. there is a mechanism to ensure that only proper hierarchical patch structures are created.
however after setting up a cyclical patch structure there could be plenty reasons that vvvv gets into an endless loop somewhere.

sorrily i can’t reproduce the bug, and also can’t think of any way how to get around this mechanisms, which avoids creating patches in themselfes.

so: its not possible. ;)

so: its not possible. ;)

nei nei gregsn; it is possible but on a low machine. im trying to reproduce bug with the file ( here).
just opening “trichromie” subpatch and replicate with Ctrl-D schwz-artnet subpatch.

this happens on my low machine, wich is a 1.6ghz mono proc with 512 M of ram.
this doesnt happens on my tower, wich is quadcore … ;-)

cabaret.zip (416.2 kB)