Forum

2-d wave simulator not showing in projector

Hi,

I am using a projector as a second monitor to my computer, both displays use the same video board, a GeForce 8800 GTS with two DVI outlets.

Unfortunately, when I use the wave simulator patch v.2 (2d version), the wave is rendered correctly on the regular monitor, but not on the projector. I have tried change the texture mode on the patch and changing color, frequency and resolution of the second display (the projector) but the wave does not show.

Also, if I put the renderer window totally inside the second display (i.e., move it) and get back to the main display (monitor), the wave disappears and do not appear anymore. I have to restart vvvv to see it again.

It really seems like a bug in vvvv, but as I am a novvvvice I though I could ask here first. :) Please apologize if I’m wrong.

Thank you!

helo canadian,

your facing a (tough) known problem. if youre goal is to just get the wave-renderer running on the second monitor (no juggling with the renderers between first and second display) you can use a workaround: make sure you save the patch with the renderer-window placed to the second screen. then start vvvv with the
/dda 1
option. where 1 denotes the second display (or 2 would denote a third display, if you had one). this way vvvv would create devices on startup on the correct display already and not fukc up.

this problem concerns all situations where a patch uses a renderer- loop, i.e.: renderer->dx9texture->queue->quad->back to same renderer

Hey joreg, thanks for the reply!

I just tried to do what you suggested: I saved the patch with the renderer in the second display (the projector) and loaded the patch with the argument /dda 1. Two things happened: when the renderer was fullscreen-sized the patch loaded with a blank second display and didn’t “run”. The frame counter pin of the MainLoop node was zero and didn’t go up. Then I tested with the renderer window normal sized (not fullscreen) and saved the patch again, and when I loaded the patch it was a gray area where the wave should be rendered.

I didn’t know that was a known problem. It seems I have a lot to learn then. :)

Oh, and as for the name, it’s actually my last name. I am from Brazil, not Canada. :)

Thanks again!

elo,

sory for the late reply. actually i have no more idea. /dda 1 works for us in all those cases. as mentioned it is a bug though and we’ll have to work that out one day.