1st renderer outputs smooth shape, but when using its output as texture, renderer 2 displays pixelated version

Full resolution screenshot


When setting Renderer 1 “AA Samples per pixels” to 32, the topmost shape becomes smooth. However, when trying to use its output as a texture, it becomes pixelated again, despite enabling the same setting on renderer 2.

I don’t know anything about graphics programming for the time being, so troubleshooting is a bit difficult.

I’m using DX11, by the way - I couldn’t find a way to achieve smooth shapes with DX9.

For the first renderer, use Renderer (DX11 TempTarget)

There you can set Texture SizeXY or use the Actual Backbuffer SizeXY output of the final Renderer (DX11)

I’ve tried all kinds of settings, but I can’t get it to work. I’ve attached a v4p.

By the way: Is there any way to achieve smoother graphics in DX9? I find DX11 nodes to be slightly tedious to work with, having to use segment geometry through constant (rather than simple layer in DX9), having to use a blend node to get alpha/transparency, missing certain DX9 nodes, etc.

smooth-notsmooth.v4p (6.4 kB)

Actually, I figured out how to do it with the EX9 renderer:

I had to show EX9 renderer in the Inspektor, and choose Window Antialiasing. Now everything works the way I want it to. I’m surprised this is disabled by default and hidden.

When I started with vvvv, antialiasing pin was a wonderful discover. Anyway, that pin and the other of the same group are called configuration pins. These pins should not change each and every frame.